Not being able to intall packages or themes

I tried both using the gui and using apm

This is the error message (same for gui and apm):
`node:internal/modules/cjs/loader:479
throw e;
^

Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath ‘./bin/npm-cli’ is not defined by “exports” in /usr/lib/node_modules/npm/package.json
at new NodeError (node:internal/errors:329:5)
at throwExportsNotFound (node:internal/modules/esm/resolve:337:9)
at packageExportsResolve (node:internal/modules/esm/resolve:562:3)
at resolveExports (node:internal/modules/cjs/loader:473:36)
at Function.Module._findPath (node:internal/modules/cjs/loader:513:31)
at Function.node_module._findPath (/usr/lib/node_modules/atom-package-manager/node_modules/asar-require/lib/require.js:141:32)
at Function.Module._resolveFilename (node:internal/modules/cjs/loader:911:27)
at Function.resolve (node:internal/modules/cjs/helpers:98:19)
at new Install (/usr/lib/node_modules/atom-package-manager/lib/install.js:53:34)
at Object.run (/usr/lib/node_modules/atom-package-manager/lib/apm-cli.js:240:18) {
code: ‘ERR_PACKAGE_PATH_NOT_EXPORTED’
}
`

I’m using Arch Linux x86_64
My kernel is 5.10.14-arch1-1
Npm version is 7.5.6

1 Like

Same issue, same message error. Using Manjaro x86_64. Kernel is 5.10.18. npm version is 7.6.0

Same issue here.
Arch Linux x86_64
Kernel 5.11.2-arch1-1
npm 7.6.0

Try this. It worked for me.

Arch Linux x86_64
Kernel 5.11.2-arch1-1
npm 7.6.1
Atom : 1.54.0
Electron: 6.1.12
Chrome : 76.0.3809.146
Node : 12.4.0