Not able to use apm manager


#1

Hey,

I’m a new user of the atom editor. I really appreciate atom compared to other editors (notepad++, geany etc.)(love these highlightings _). So far I only used atom for programming PHP, JS, CSS, and HTML and had no needs to install packages. But now I’d like to use latex in atom. For this, I need to install latex-package with apm manager from the commandline. The command sudo apm install latex results with the error : sudo: apm: command not found.

I installed atom by hand, downloading the .zip file on the related website of atom (for Debian 9). The path to atom is in the home directory of mine and also the apm-manager is located in this path (/home/myuser/Atom/usr/bin/apm). I’m not really sure where to place apm, the previous location does not work. I appreciate any help!


#2

…perhaps try it this way ->


#3

Already tried, it seems i cant connect to the repository…


#4

That is not so nice.
Build code or web connection at fault?.. I do not know.


#5

Looks like apm is not in your PATH environmental variable:

export PATH=${PATH}:/home/myuser/Atom/usr/bin

Off-topic: If moderators would post a general post regarding PATH and terminal integration (the most asked questions), this forum would probably be dead. But then again, if users were using search, it would be just as dead :wink:


#6

What you say makes sense for invoking apm from the command line / shell / terminal.

However… in my case I do not have apm on my path ->

But is is possible for me to update / download packages from inside Atom. That is true for a regular installation (V1.19.7) and also portable installation (V1.20 - Beta 7) on a Windows7 machine. (On another PC I have an earlier Atom version… same result.)

Though I agree we should have some FAQ about what / why PATH for all the different OS flavours.
Any thoughts on why the GUI also does not work?

Regards.


#7

I figured out where the problem is. I’m working in an institution with high security level. So the connection to an other repository can only be managed by using a proxy. Furthermore my boss forbid me to install any package manager except apt and dkpg, he told me a package manager could cause secure gaps. (don’t know why?)
The only way how I’m able to install atom-package, seems to refer the repository of atom in the sources.list by using a proxy. I searched for a long while to find the http-url, which refers to atom’s Debian repository, but cant find… Can someone help?


#8

The last time I checked it was @N3wbie who had a problem running apm, not you. Besides, we already adressed your lack of shell commands in a different thread.


#9

Thank you for your feedback.

Any addition to your Atom installation has a potential security risk.
I have tried to block the “phone home” behaviour within Atom and did not have any joy.
This behaviour is not only from Atom’s core but also the installed packages.
Now it is blocked by the firewall.

Good luck for finding a solution that fits your needs.


#10

You are right.


#11

Because it’s possible that one of the dependencies being pulled in could be compromised by a malicious actor. It’s not very likely, but it’s possible. APM is built on top of NPM and uses a lot of Node packages, which the security hounds at your organization aren’t going to like.

I searched for a long while to find the http-url, which refers to atom’s Debian repository, but cant find…

Atom doesn’t have an official Debian repository, and even if it did, you would still have to use APM to install packages.


#12

I gave up installing a latex plugin for atom, without using apm it seems senseless. But thank you both for response!