Not able to install any package on my atom


#1

Every time i want to install any package (like atom-broadcast, preview etc) It gave me error as shown below . Please Help!!

Installing “broadcast@0.4.0” failed.Hide output…

oniguruma@7.0.2 install C:\Users\Nabeel\AppData\Local\Temp\apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9\node_modules\broadcast\node_modules\oniguruma
node-gyp rebuild

C:\Users\Nabeel\AppData\Local\Temp\apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9\node_modules\broadcast\node_modules\oniguruma>if not defined npm_config_node_gyp (node “C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\npm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild )
C:\Users\Nabeel\AppData\Local\Temp\apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9
`-- (empty)

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\node-gyp\lib\configure.js:449:14)
gyp ERR! stack at C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\node-gyp\lib\configure.js:404:11
gyp ERR! stack at C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command “C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\bin\node.exe” “C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\Nabeel\AppData\Local\Temp\apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9\node_modules\broadcast\node_modules\oniguruma
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\Nabeel\AppData\Local\Temp\apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9\package.json’
npm WARN apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9 No description
npm WARN apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9 No repository field.
npm WARN apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9 No README data
npm WARN apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9 No license field.
npm ERR! Windows_NT 6.1.7601
npm ERR! argv “C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\bin\node.exe” “C:\Users\Nabeel\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\Nabeel\.atom\.apm\.apmrc” “–userconfig” “C:\Users\Nabeel\.atom\.apmrc” “install” “C:\Users\Nabeel\AppData\Local\Temp\d-11898-6644-118c027.bqmxs3v7vi\package.tgz” “–runtime=electron” “–target=2.0.5” “–arch=ia32” “–global-style”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! oniguruma@7.0.2 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the oniguruma@7.0.2 install script ‘node-gyp rebuild’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the oniguruma package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs oniguruma
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls oniguruma
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\Nabeel\AppData\Local\Temp\apm-install-dir-11898-6644-1bbop5j.f5trg7rpb9\npm-debug.log
npm ERR! code 1


#2

Have you tried reinstalling Atom? One of Atom’s dependencies is the oniguruma regular expression library, and from the sound of the error message, that might be what’s having the problem. The weird thing is that you shouldn’t ever install oniguruma unless a package has it as a dependency, which broadcast does not. So it may be that something went wrong with Atom installing the first time and one of the modules it needs isn’t in place.

It seems like, since NPM thinks that it has to install oniguruma and oniguruma relies on building C++ code to work, the actual error is encountered when NPM calls on node-gyp, which requires that Python and Windows build tools be installed. If reinstalling Atom fixes the problem, you don’t have to do anything further, but if it doesn’t, you might be able to work around that by setting up your computer with the build tools and letting NPM build oniguruma.


#3

Yes, every time i have to reinstall atom for running a particular package smoothly, same error happened when i tried to install atom-bootstrap3, atom-html-preview etc. I have to reinstall atom and reinstall the packages to get it work.