Not able to change word-break in the atom-runner styling

Using the atom-runner package - https://github.com/lsegal/atom-runner

Default styling - https://github.com/lsegal/atom-runner/blob/master/styles/atom-runner.less

I’m overriding some of these in Atom. File > Stylesheet

.atom-runner {
  font-size: 70%;
}

.atom-runner pre {
    word-break: break-word;
    font-size: 255%;
    height: 80%;
}

.footer {
  word-break: keep-all;
}

Noticed that word-break doesn’t work as I expect.

Also tried word-wrap: break-word;
Want to wrap words in the pre-formatted output.

Another question is how to make output pane always loads on the right side. Now it loads in the botom, and I’m manually putting it on the right side. ‘Settings - Pane Splits Direction - Right’ doesn’t work for me. It loads together with other package at the bottom.

The CSS3 syntax is white-space: pre-wrap;.

atom-runner is fully in control of where it creates its output pane, and changing the rules would require changing the code of the package directly. Given that it’s been abandoned for three years, this is something you’d have to do yourself. I can tell you how if you decide that you want to attempt it.

1 Like

Sorry, I did not specify that I was able to change font size and some other options. I’ll try the css3 syntax, as soon as I can.

white-space: pre-wrap; have given me the desired output. Thanks! Ideally in this particular case, one would like to see the line breaks not in the middle of the list elements, but I guess it’s not possible.

It’s not possible with CSS. The JavaScript that takes the output from the interpreter and displays it in Atom is where that sort of intelligent formatting would have to take place.