Noob question on autoclose-html


#1

Right. So I’m quite new to coding, and I have a question that reveals that fact.

I’ve installed the autoclose-html package, and I’ve disabled all autocomplete (because I’m trying to learn the code, and auto-completion might hinder that). When I try to type something like:

<meta charset="utf-8">

everything is fine until I type >, and then /> is generated (or / with a greater number of >s). I don’t want the backslash in there. How do I type a line like the one mentioned and close it without the additional and unwanted characters?

Thanks in advance for helping out a noob.


#2

Have you taken a look at the README for the autoclose-html package? (Which is also available in the Settings View.) It mentions:

Never Close

Elements in this comma delimited list should not render a closing tag

It looks to me like some combination of configuration would work for you.


#3

Yep. If I deselect the “Make Never Close Elements Self-Closing” option, that fixes it for me. Thanks.