Noob problem with atom's interface


#1

Hi guys, I probably did a mistake but i have been searching a solution for 1 hour and nothing. I’m currently learning C and i use Atom for edit my code but since but since yesterday i got this interface (that i never seen before) :

How can I back to the usual interface ?

Thanks for your help =D


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

Try clicking the little smartphone icon on the top bar of the white panel at the bottom (next to the magnifying glass). That interface is part chrome debug tools that allow you to view a webpage on a smartphone sized screen.

EDIT: Additionally, closing the bottom panel would work as well I think.


#4

Leedohm, i’m using atom 1.6.0-1~webupd8~0 on Ubuntu 14.04 LTS. I had completely re-install atom 3 times and no changes, even with atom --safe command line. After reading the Debugging document, i check the console :


but i don’t know what kind of error it is.

StenV, i tried to click on the little smartphone icon but it just show me a white window.

This is a really weird issue because i used atom ten day ago and all was normal and now the interface completely change (it doesn’t even look like the same software).

Thanks for you help


#5

We don’t support the webupd8 PPA installation. Have you tried installing Atom from the version on the website at https://atom.io? Also, you may want to try:

  1. Exit all instances of Atom
  2. Move or delete the ~/.atom/storage directory
  3. Start Atom again

#6

I tried to install atom from differents ways. The PPA is deployed by webupd8, the official .deb can’t be installed cause : “wrong “amd64” architecture” (maybe because my hardware isn’t compatible). And for the .rpm I’m missing the lsb-core-noarch (I’ve installed the lsb-core but no changes). To be sure I’ve deleted the directory of atom (/home/User/.atom) and re-install from PPA but i get the same interface.

I don’t know why the amd64 architecture is incorrect but it’s probably a package or a driver I have not installed. I will search how to install it and retry.


#7

Apparently, a 32bits OS can’t run a 64bits app. Why Atom haven’t a 32bits version ?
If you are active on this forum is that you must be an active user of Atom, have you ever seen a interface like this in Atom ?