NONE of the terminal packages works for me

Hello, to be short, none of the package terminals works for me.
there are two types, of “not working”
the first one was environment related, like having python 3 instead of 2
which was solved.
but the real issue i am encountering is for every successful terminal installation
(i literally tried more than 10 of them)
the terminal comes up and freezes at the curser blinking interface, with the default dark background,
i cannot type in it, nothing shows up after giving it time to load.
and i havent really seen anyone encountering the same issue as me, of all terminal packages not working.
others genre of packages however works perfectly fine.
Am i missing something blatantly obvious?


atom version:1.39.1 x64
operating system: windows10 home x64 version.1903


p.s. is there anything else i need to include?
or is there somewhere i can check out the error log to further dive into it.

I’m sure someone has hidden the answer in one of the following posts:

Otherwise, search is a powerful feature on this forum.

thank you for the kind reference!
and the humorous means of doing it