Noedgit module error when building exectuable


#1

Hi all,

Been stuck on this error a few days, would love it if someone could explain what is happening / provide a workaround.

I am using the nodegit module to pull the git history of a user directory. It works perfectly fine in dev mode. The problem is when I build the app I am getting the following error:

I think the problem is that electron packages its own node js run time, when this module is built again an earlier node version.

I have tried several build commands but they haven’t worked. This is my package.json scripts:

Does anyone have an idea about how to get this running?