Node: command not found


#1

In atom 0.75.0, I’m getting an error when trying to install a third party package (Todo Show) that ultimately depends on node-gyp. In 0.73.0, I can install the package fine; however it fails in 0.75.0:

/Users/tim/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/node-gyp-bin/node-gyp: line 2: node: command not found

It looks like Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node was renamed to node_darwin_x64, which prevents the node executable from being found by node-gyp.


#2

Can you reinstall Atom 0.75? (can be downloaded from http://atom.io), because using the same version I was able to install from command line and from the Settings.

Maybe reinstalling can fix that.


#3

If you open Atom from the console instead of the GUI launcher, it will have your environment variables which likely include the PATH for node.

Check out rgbkrk/atom-script/#61 for other tricks if you really want to open everything from the icon.


#4

@AbeEstrada, I actually did a fresh install of 0.75. I run from ~/Applications/Atom.app since I run day-to-day as a non-administrative user, so the auto updater doesn’t work and I have to manually download the new version every time.

Do you have a standalone node installed? I do not as I’ve been relying on the node bundled with Atom, which looks like it was renamed between 0.73 and 0.75. If you do, I expect node-gyp finds this node and runs successfully. I was under the impression that having a standalone node installed was no longer a requirement for Atom.

@rgbkrk, thanks for the link. I’ve run it both from the command line and the GUI. As I mentioned above, I don’t have a standalone node installed.

BTW, the author released a new version of Todo Show (0.3.0) which removes the dependency on pathwatcher (which I believe is where the node-gyp dependency was coming from) and it now successfully installs in 0.75. I think the renaming of the node executable is a bigger issue though.


#5

@rgbkrk just wanted to say thanks for the suggestion on opening from console, as I was having a similar problem installing the package Atom Color Highlight w/ Atom 0.81.0, whereas in my case Todo Show installed fine for me when running Atom from the GUI launcher. But running from console alowed me to install the trouble package. So thanks!