No welcome screen


#1

I have installed atom 1.31.1 from deb package on linux mint 17.3, when i run atom from terminal, i don’t get the welcome screen. How do i get it?


#2

Do you just want to look at it, or do you want it to appear every time by default?


#3

I didn’t relise you need to start atom with sudo. I think it was starting in safe mode. Thankyou for replying.


#4

You don’t. That’s a bad idea and only masks any current issues.


#5

If you need to start Atom with sudo, that means that you need to delete the ~/.atom/ folder and reopen Atom without sudo so that it will create a new one that you have permission to access.

You can tell if Atom’s in safe mode because it has a little green block on the left side of the status bar. All community packages and your settings are disabled in safe mode, but core packages (like welcome, which is what generates the view you’re looking for) are not.


#6

I did that and it worked. I also think you solved my other issue with loading pymakr plugin…it started working. Thankyou so much.


#7

No problem. :slight_smile: