No syntax highlighting in *.html.haml files,


#1

I don’t get syntax highlighting in my haml files.
I’m working in Rails, so the extension is filename.html.haml. Does that have anything to do with it?


#2

Syntax highlighting for HAML doesn’t come installed with Atom by default. There is a language-haml package though.


#3

Lightning fast reply, awesome.
I was going to complain:

but I have already that package…

No, I don’t. I have language-yaml, haha :blush:
I should take a rest.
Thanks.


#4

Not getting syntax highlighting for Haml with atom (v1.27.1). Also when I search for packages related to haml I can’t find anything. Any way I can get syntax highlighting for haml to work?


#5

Odd. When I do it, I see a bunch of results, the first of which is the language package that was mentioned earlier in this thread.


#6

I am searching from within the atom editor.


#7

How do I install package from outside?


#8

I don’t think you’re searching the package registry at all. I think you’re searching your local packages under the Packages tab. You need to go to the Install tab.


#9

You are right. Thank you. Haml package is installed and working as expected. :slight_smile: