No scrollbar on certain files


#1

Hi!

I’m working on a GitHub project on my Ubuntu 16.04, and just recently updated Atom to 1.26.0 x64.

After the update, I’m not able to scroll (vertically) on some files. My impression is that it is only recently changed files that fails (ie. files marked with yellow in the tree view), other long files works fine to scroll up and down.

I also notice that it actually scrolls in the background, ie. when I scroll with the mouse, nothing happens on the screen, but when the display is updated, the file is moved to that position some lines down in the code.

Visually I can also see that the scrollbar (on the right side of the file window) is missing when this happens.

This is valid for different kind of files I have (c,h,mk etc), but it is not valid for all files (i.e. similar to this case, but again, it is not on all my files, only some of them: [Solved] Scrollbar not appearing in main files).

Best regards,
Thomas


#2

Update!

If I close the file tab for a failing file (no matter if I have edited the file or not - i.e. I don’t have to save the file again) and open the same file again - then it works! I can scroll the file and the scroll bar appears. And if I exit Atom and start it again, the file is still ok - so I now have a way to circumvent this problem.

I earlier tried to re-install Atom from scratch (removed all installed files etc) but that didn’t help. Is there any information about the files stored locally that has to be updated?


#3

Does the problem occur when you open Atom from the command line with atom --safe?


#4

Yes, using option --safe doesn’t help, I still have the same problem.


#5

I haven’t seen anything like this before, so I’m not sure if I can help at all. If you go through reinstalling Atom and using --safe and an issue persists, then it would seem like it has to be due to an interaction between Atom and the environment. The next thing to find out would be if other Ubuntu-residing Atom installs can be made to forget about scrollbars for changed files. If someone can figure that out, then the puzzle will be solved.


#6

Thanks for you help anyhow!

The only explanation I have created for myself is that the previous version I had installed (I don’t really recall which, but I think it was 1.9-ish), has saved some local information about the files and open projects. And when 1.26 reads this information it fails somehow on some of the files (the changed ones according to git?). Again, if I close the file and reopen it, everything works ok again (for that file), but it doesn’t help to just close Atom and restart. But I guess that closing all files and open them again would do the trick.
Also I open a new directory (which hasn’t been open with the previous version), then everything works ok.
So I assume that Atom saves some cache information somewhere which isn’t fully compatible between older versions and 1.26.

Just my two cents …

Cheers,
Thomas


#7

You can test your theory about some cached information by doing quitting atom and then doing:

atom --clear-window-state

from your project directory.


#8

Hi dpriedel1,

Yes, that worked fine! :smiley:

I guess that would be the same as closing all files (all tabs) from the menu, but maybe other strange behavior is also lost by doing a clear-window-state (I have e.g. seen some cases where some entries in the top menu are duplicated - like “File Edit Edit View Selection Find Find”).

Hopefully your tip helps out!

Cheers!