No kernel for grammar null grammar found


#1

Hello there,

I am not much of a programmer and just downloaded atom. I need to fit some curves with python for a class. I found a package on atom called hydrogen that seemed to have what I need. I added three packages, Hydrogen, python autocomplete, and script. Whenever I try to execute any code, whether its just regular python code or code from the hydrogen package I get a red error message saying
Capture
Also, the code I write has no colors when key words are typed, even though I have a theme selected. Any help would be appreciated, its probably something really stupid I am doing


#2

You haven’t shared much information about what you see on your screen, but based on the behavior of Atom and the hydrogen package, I’m guessing that you haven’t saved your files or haven’t given them file extensions. Atom relies on the file extension to tell what language you’re working with.


#3

Thank you very much, not including the extension was part of my problem. So, now the theme is showing up, however I still get this error when I run something with hydrogen code:
Capture2
When I try to run the code in the error picture the same error pops up.

Also, thank you very much for helping out. You have no idea how much I appreciate it. Please let me know if you need additional information


#4

That isn’t Python code. Those are command line instructions. You need to open your system’s command line interface to run them. You will also need to install Python if you haven’t already.


#5

I do have python installed already, (C:\Python27\python.exe). I open up my command line (cmd correct?) and I input the lines but receive, ‘python’ is not recognized as an internal or external command, operable program, or batch file.

Sorry, I am pretty illiterate when it comes to this sort of stuff, I appreciate you sticking with me though.


#6

Figured it out. Had to include C:\Python27\Scripts in my paths.

Thanks again for the help earlier.