No highlighted text?


#1

Hi,

I have no idea how but somehow I don’t see any highlighted text in my Atom editor. I’ve tried different UI and syntax themes but I can’t seem to get it to work as usual. This has not been the case since I started using the editor and I indeed think that it surfaced when I was switching syntax themes. But then again, it doesn’t work as usual with the standard atom themes either.

Would be super if someone could help me, thanks in advance.

Greetings & with kind regards,

dcktf


#2

update: it’s just in the HTML editor


#3

Does this happen when you start Atom from the command line with atom --safe?

You can also go into Settings -> Packages, search for “language-html”, and make sure that you don’t have two of them or something.

By this, do you mean it’s only when the grammar is set to HTML?


#4

Thanks for your response! With safe mode it’s not the case. Does that mean there is a double entry or something? Yes, it’s only when the grammar is set to HTML indeed.


#5

It means that the problem is a package you have installed. You should go through and disable packages one at a time to see which one is causing the issue. The possible cause that comes first to mind would be if you had a package in .atom/packages named language-html, which would then override the built-in HTML grammar, but since I don’t know what packages you have on your machine, I can’t tell you exactly what’s causing it.