No folder tree with `atom .` and other issues after 0.131.0 upgrade


#1

After upgrading to 0.131.0, when I use atom . to open a folder there is no folder tree shown and I am unable to toggle it.

If I go through File->Open… and select the same directory then atom opens with a folder tree present.

Is anyone else seeing the same issue? Is there any further info I can provide to help debug?

I’m running on OS X Yosemite.


#2

Actually, there may be a deeper problem here as I have to perform twice any action that would open an editor (ie. click file in tree twice, click File->Preferences twice, etc).

I have tried switching to the default theme and disabling any recently added packages but to no avail.


#3

Looks like I’m suffering from (at least) this issue with the Sublime Tabs package: https://github.com/ddavison/sublime-tabs/issues/41


#4

I’m not currently on yosemite (I’ll be able to test tonight at home) but I don’t get this on maverick.

Have you tried with the --safe option? (in case it’s an issue with a package that became incompatible)


#5

Disabling the Sublime Tabs package has fixed the tree view issue. Main issue I have now is that I have no tabs at all so it’s difficult to navigate between files. --safe didn’t appear to make any difference.


#6

Ok, back to a working system now. It seems as though somehow both my Tree View and Tabs packages were disabled during the upgrade and I had to toggle on/off/on to get back to a working state.


#7

In case any of you were following this thread:

This issue was resolved. The sublime-tabs package actually extends the Tab view, and per @kevinsawicki, there was a change introduced to the tabs package, which broke the sublime-tabs package.

Good news is: This has been fixed!

The long term goal with sublime-tabs is to get it implemented into the Core of atom, but still haven’t found the time to do something like this yet.