No Coloring by Gedcom language package


#1

I installed the language-gedcom package and the required gedcom-theme-syntax from d5dhatch David M. Hatch, restarted atom, loaded a .ged file but no coloring showed up. There is still the black letters on white background.
At the page of “language-gedcom” there is a not:
Updated regex for gedcom here: https://regex101.com/r/Y17Z72/5
What does this mean? Do I have to download and install additional packages?

What I have to do, to get the coloring correctly. This is my first use of atom.
Thanks and best regards


#2

When you open the .ged file, look on the right-hand side of the status bar and it will tell you what language is active. It should say GEDCOM, but it might say Plain Text or something else. Have you activated gedcom-theme-syntax, as well?


#3

DamnedScholar https://discuss.atom.io/u/damnedscholar
December 18

When you open the |.ged| file, look on the right-hand side of the
status bar and it will tell you what language is active. It should say

GEDCOM>, but it might say |Plain Text| or something else. Have you
activated |gedcom-theme-syntax|, as well?

Yes, it says GEDCOM and yes, I installed also the gedcom-theme-syntax.


#4

But have you activated the syntax theme? You have to switch to the theme, under Settings -> Themes.


#5

I believe, I did. Here the screenshot


#6

When I install both of those packages and activate the Gedcom theme, I see syntax highlighting.


#7

Hi Damned,

I forgot to ask, why do you have an abstract of the ged-file on the
right column of your screenshot?


#8

You may find the following of value:
https://atom.io/packages/minimap

Was your original query resolved?


#9

Hi Dan,
thanks for the info.

And No, I still have an issue. One of my 2 mails from yesterday doesn’t show up.
Therefor I’ll resend it again - one ged-file is colored, another one is not colored. But I do not see a difference between both instead the content. The screenshots are part of my reply


#10

Because I only can add 1 image per post, here the 1st one, next post the
2nd one, where no coloring shows up
i


#11

and here is the 2nd one, where the syntax coloring is working.

I don’t know the reason, but so far I only tested by the 1st file and
therefor all my past posts were related to that one.
Both files do have the extension “.ged”.
Any idea, why we have this difference?

Best regards


#12

The un-colored file probably isn’t being recognized as GEDCOM for whatever reason. Try changing the active language.


#13

It seems to be the size of a ged-file, which impacts the coloring.
Small files get colored, large files (not known, when) will be without any effect.