Newbie: Unable to run a Screen share chrome app using electron


I ran app successfully under chrome extenstion. But when I run it using electron the socket connection Error in connection establishment: net::ERR_CONNECTION_REFUSED

Below is package.json file. I tried “chromium-args”: “–allow-running-insecure-content --ignore-certificate-errors”, but did not help.enter link description here
Are There any specific changes I need to make in package.json. Just trying to learn let me know if any information is missing?

“name”: “electron-app”,
“version”: “1.0.0”,
“description”: “”,
“main”: “main.js”,
“icons”: {
“16”: “icon.png”,
“128”: “icon.png”
“chromium-args”: “–allow-running-insecure-content --ignore-certificate-errors”,
“app”: {
“background”: {
“scripts”: [“background.js”]
“sockets”: {
“udp”: { “bind”: “", “send”: "” }
“permissions”: [
“”, “desktopCapture”, “videoCapture”, “mdns”
“dependencies”: {
“pretty-bytes”: “^2.0.1”
“devDependencies”: {
“electron-prebuilt”: “^0.35.2”
“scripts”: {
“start”: “electron main.js”
“author”: “”,
“license”: “ISC”
► Run code snippet


I am sure it is not the firewall. And it is failing to get connected to ubuntu server. Is there something an electron app requires to be installed before you run chrome app running screen-share webrtc app?


Were you able to find the solution to this problem? I run in the same problem when wrote a wrapper around Google Calendar site which uses Google Meet and when trying to do ScreenSharing from Google Meet I get an error.