Newbie Install Question on RHEL without sudo


#1

Hello Atom,

I evaluated atom on my personal Windows machine and loved it!

I want to use this as everyday editor at my work, where RHEL 6 is OS.
Unfortunately I do not have a sudo access.
I used to install software that I need from tar.gz in my local dir and add them to $PATH.
Is there a way to install atom like this ? Without sudo and in my local dir ?
I cannot install it in /usr/bin or any / locations.

Please help!
Thanks.


#2

I also would like to know how to do this! Any help please? Thanks a lot!


#3

You ought to be able to download the tar.gz file from the GitHub releases page under the version you want.


#4

I should have informed first that I’m a total newbie who works as a hardware developer with the following setup: main OS is Windows 8 on my laptop, then I connect to a GNOME desktop environment thru VNC Viewer. I use gvim for editing source codes. Now I stumbled upon atom and I’m amazed at its functionalities and its looks. How can I install it in my Unix home folder and use it without having sudo privileges? I followed the steps from the readme and it failed and said something like “this will be reported.” – Will this get me into trouble?


#5

Yes. You’ve been added to Santa’s naughty list :smile:.

(Seriously though, you can do whatever you like with Atom. The message you saw was probably the generic “somethings gone wrong. This issue has already been reported”)


#6

Have you tried the tar.gz file like I suggested?

I followed the steps from the readme and it failed and said something like “this will be reported.”

I know you’re a newbie, but for a developer, you clearly aren’t used to giving precise and informative statements.

  1. What steps? If the file in question is a markdown file on GitHub, every header has an anchor link that you can copy to give us a direct link to the text you’re talking about. Not providing a clear indication of which documentation you are consulting makes it harder for us to get on the same page as you.
  2. Pronouns are uninformative. I don’t know what “it” is.
  3. Error messages generally contain a lot of useful information about where things went wrong. If you paraphrase messages from the software, as someone who doesn’t know what information you’re looking for, you’re going to throw out everything that you should be trying to communicate to us.

#8

My apologies, I only give very detailed info when I’m reporting and fixing bugs at work :sweat_smile:. Outside of “it” (i.e. work), I always type out stuff hastily and never even double check. I even get downvoted most of the time here for the same reasons :joy:


#9

Ok I had a bit of downtime now so here’s what I did:

  1. Downloaded “Source code (.tar.gz)” (sorry, I’m only allowed 2 links in a post) and untarred it in my /home/ folder using tar -xvzf atom-1.29.0-beta0.tar.gz.
  2. Browsed through README.md and the *** Archive extraction caught my attention because the description was “An archive is available for people who don’t want to install atom as root.” The steps are:
    a. Install dependencies (on Ubuntu): sudo apt install git gconf2 gconf-service libgtk2.0-0 libudev1 libgcrypt20 libnotify4 libxtst6 libnss3 python gvfs-bin xdg-utils libcap2
    b. Download atom-amd64.tar.gz from the Atom releases page.
    c. Run tar xf atom-amd64.tar.gz in the directory where you want to extract the Atom folder.
    d. Launch Atom using the installed atom command from the newly extracted directory.

To my ignorance, I skipped step (a) since the sudo command is resulting in <user> is not in the sudoers file. This incident will be reported. I did steps (b) to (d), and finally in step (d):

% atom
atom: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory

Can I install the dependencies with my current setup? Thanks a lot in advance!


#10

Yeah, you’re right. I’ve used Arch Linux, and that has a package manager that explicitly prevents you from using sudo, but I hadn’t used Red Hat and so I wasn’t fully aware of all the options. I did some research and spun up a Fedora Linode to test, and I can confirm that this method works to download Atom. I don’t know 100% that you will be able to run it, because it still relies on external dependencies. But this will get you a compiled Atom in a folder on your computer.

mkdir atom-download 
cd atom-download
wget https://github.com/atom/atom/releases/download/v1.28.1/atom.x86_64.rpm
rpm2cpio atom.x86_64.rpm | cpio -idmv

Once it’s done, you can confirm with ./usr/bin/apm, which will pull up the APM help screen. At that point, you can use it directly from where it is, or you can set up a more enjoyable path for you to write out and/or create symbolic links from your user folder (which would work just like desktop shortcuts, except that they would work both from the GUI and the command line).