(new to programming) need help installing package


#1

Hi everyone,
I am new to programming. I cannot install some packages via setting. It returns some errors like this:
npm ERR! not found: git
npm ERR!
npm ERR! Failed using git.
npm ERR! This is most likely not a problem with npm itself.
npm ERR! Please check if you have git installed and in your PATH.

So I also tried to install packages manually using “apm install” in cmd at the unzipped new package folder(~/.atom/packages/something). But it fails and returns the same errors.

I am using windows 8.1, atom version 0.156.0, also have git installed (from
git-scm website)

After searching around forum, I cannot solve it (also tried reinstall, delete .atom folder). Could someone help or will it be fixed in next update?


#2

Looks like a duplicate of this other topic:


#3

Thanks for your reply.

Finally, I solve the problem. During git installing process, I forgot adjust the PATH.