New option "Auto Indent On Paste" behaves badly on CoffeeScript


#1

The new option Auto Indent On Paste is unusable with languages like CoffeeScript (or Python, Haml, etc.).

This is related to https://discuss.atom.io/t/coffeescript-auto-indent-broken/ .

However, this is a global option, so it cannot be disabled for CoffeeScript files (or can it?).

I guess the best behaviour when pasting CoffeeScript lines should be: just paste the lines and don’t bother trying to fix indentation.


#2

Hi @giorgian,

These settings can be defined on a per-language basis, and we have done exactly that in the latest release. We have disabled Auto Indent on Paste in all of the bundled packages for whitespace-sensitive languages (Sass, CoffeeScript, Python and YAML). Thanks!


#3

Hi @maxbrunsfeld,
That’s great, thank you!