New language package not showing on status bar's language list

The package language-edl can recognize .edl files when these are opened and sets the grammar location on the status bar to Enclave Definition Language. However, if we open the grammars’ list on the status bar in the bottom right this language is not shown there.

  1. What could be the cause of this?

  2. Do I have to somehow explicitly invoke the API of status-bar?

  3. Could the problem be related with tree-sitter-edl (NPM registry) instead of language-edl?

Tree sitter grammars don’t appear yet, because there needs to be some work out in to make them look different from the TextMate ones

It’s in progress here

1 Like