Need some help to explain my recent foundings


#1

Hello, this is my first day on this forum and I’d like to ask something about a recent behavior that i got.

This strange behavior happened whenever I tried to open a new file (from the left pane where I list all of my project folders) on partition in exFAT (a local drive), but what I got is a yellow notification with “Socket is not connected” error message. So then I tried to look for the file with file manager but it couldn’t get the job done either as it shows another error with “transport endpoint is not connected” message. Opening a file from the menu doesn’t work either.

I am using Solus (Linux, 64 bit) and this happens since v.1.23.2. I’ve tried safe-mode and it still persists. When I dig into the settings and change the file system watcher to the emulated ones, it solves the problem.

But then since I don’t know much about how atom-watcher works, I turned it back to the native ones and when I scrolled down a bit, I saw the “project home” part and I remember that I used to setup a specific directory (the ones where I stored all of my project files, I mean my local git repo) which is on the same partition as where the problem start all the day. So I left that box empty (default) and it also solves the problem.

But I was still feeling curious about the problem, so I tried to reproduce the problem by setup a folder in a NTFS partition (where my Windows 10 sits) as the “project home” value to see if it would broken the partition. But no, the problem kicks in again only when I tried to open a file from the previous partition. The partition that I’m talking about was in exFAT.

Is this one of the reason for atom-watcher to be there as a second option ? or is this more likely to be a hardware / OS specific problem ?

Thanks, Good night from Indonesia!
Sorry for being less technical.


#2

It can also corrupt the exFAT partition partially, I mean if you happen to replace some files that is related to your project, all the files on that folder can gone wrong or missing. So a CHKDSK from windows is needed.


#3

I’ll try to make another exFAT partition to see if it is related to the partition type.


#4

UPDATE: leave the project home value to default doesn’t help.


#5

I’ve done the test with another exFAT partition and have set a folder inside that partition as a project home with native filesystem API as the option for filesystem watcher and everything works normally. A recent CHKDSK doesn’t found any problem, but a fsck on my linux shows a “BUG: invalid cluster number 0.” most of the times. Looks like that I will have to erase this partition and create a new one.

SUMMARY:

  • My second partition has lots of partial corruption, mostly found under .git folder due to my previous action that I just realized after.
  • Windows doesn’t seem to care much about the filesystem as everything looks normal there.
  • I couldn’t complete a full copy and paste of this probably damaged exFAT partition on linux, so I went to windows to copy all the important files to a usb stick.
  • Set the emulated atom-watcher as the preferred filesystem watcher will let you to open files on the probably damaged partition, but it will stop working again soon after doing some file copy / paste / replace inside the partition.
  • The probably damaged partition was the most possible root cause of this for now.