Need help with annoying UI


#1

Here are some design (UI) issues I’m facing, These may not be bugs but are annoying.

There is a white vertical line separator, how to remove that ? printf auto complete ends up adding a n instead of \n (May be a bug).
Selecting the line containing braces brings up a pair of horizontal lines on top of the editor, is this a feature or bug ?

Any help to solve these issues is appreciated. If they are caused by any specific theme, then can they be removed by editing the theme code ?


#2

Vertical line is the wrap guide (setting is in main settings pane), the printf auto complete looks like a bug with escaping \n in CSON. The horizontal lines also appears to be a bug.


#3

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the horizontal lines issue after completely exiting Atom and restarting using atom --safe?

#4

I’m using v0.199.0 of atom on Ubuntu 14.04. I’m not facing these issues in Fedora 21, RHEL 7,6.4, Debian and windows 8.1.
Starting atom with --safe removes the horizontal blue lines on top, but the \n is still not fixed in printf and the vertical line in the editor is lighter compared to previous which was brighter previously.
Last, Which setting will remove the vertical line in the editor ? I tried every wrap settings, nothing helped.


#5

The vertical line is from the wrap-guide package. You can go into the Settings View (Ctrl+, on Windows or Linux) and select the Packages tab on the left. Then you can search for “wrap guide”. When you pull up the Wrap Guide package in the list, just click the Disable button.

The \n in the printf snippet may be a bug, I haven’t looked into it. Please file an Issue on the language-c package.

Because the horizontal blue lines is fixed by atom --safe it appears that one of your packages is causing the issue. @mark_hahn’s package-cop package is often helpful in narrowing down which package is causing such issues.


#6

The horizontal lines seems to be gone now. But the printf and scanf auto-complete bugs still exist.
I can now control the wrap-width in style.less. I realized that wrap-guide is required for me to keep the length of lines in a decent width range, so making it invisible will work for me. Thanks.

atom-text-editor::shadow {
  .wrap-guide {    
    visibility: hidden;
  }
}