Navigation when soft tab is on


#1

Hi all,

It’s great to see that Atom is finally available in Windows. Many thanks to developers for making this happen.

I’m having a hard time trying to make the “soft tab” feature work in the same way as Sublime (or other popular editors) do. My current setting is:

Show Indent Guide: ON
Show Invisibles: ON
Show Line Numbers: ON
Soft Wrap: ON
Tab Length: 3

The issue is that, say, if I press tab key twice (to insert 6 spaces) and press backspace or the left arrow key, the cursor jumps to the 3rd position rather than going to 5th position. It seems that when there are 6 whitespaces, I can only put the cursor on the 3rd and 6th tab positions but on no other positions in between.

I’m not sure if this is intended or not but it seems a bit odd to me. Is there a way to disable this “cursor on tab positions only” feature? I searched this forum but couldn’t find any relevent thread.

Thank you,
Ted


#2

This is the expected behavior. They are “soft” tabs, but still intended to act as tabs. Just as you would hit backspace or left arrow in front of a tab and it would go back a certain number of character spaces. Whether or not you consider that a good feature is a different story.

I don’t know of a way to disable this behavior. But that doesn’t mean that there isn’t one. I actually kind of like the feature, so I haven’t bothered to look :blush: Perhaps someone else can help out … unfortunately, I’m not going to be able to look until tomorrow probably :frowning:


#3

Thanks for your reply :smile:

Yeah I can see how this can be a useful feature. It would be nice to be able to turn this off though, because it’s not standard behavior in most other editors (ex. sublime text, notepad++, eclipse, emacs, etc.)