My file tabs are gone!


#1

I am running Atom 1.16.0 x64 on Windows 7. After restarting it, no file tabs are shown anymore. I can open a file, but when I open a different file, the previous file is not shown anymore, and I can not switch back to it.

I have no idea what is causing this behaviour, because I did not change any setting related to tabs.

The attached screenshot shows the settings of my core tabs package.


#2

@rovf Have you tried it in safety mode?


#3

In addition to trying safe mode (atom --safe), the latest release version of Atom is 1.23.3 so you could also see if you’ve run into a bug that’s since been fixed by updating Atom.


#4

It surprises me that a new version is available. I had expected ‘updater’ to automatically update Atom.


#5

In safety modes, I can see the tabs!


#6

When and how did you install Atom?


#7

Sometime last year, in late summer or autumn … I don’t remember, which installation method I had used. It was working well all the time.


#8

1.16.0 was current in mid April. If you installed it in late summer or autumn, then you likely didn’t download the installer from the main page. You may have downloaded a .zip file from GitHub, in which case it doesn’t automatically update.


#9

Since it works in safe mode, I now tried to disable successively all packages to see if the error occurs. First, I disabled all my installed packages (with no effect). Then I started to disable the core packages. By mistake, I also disabled the ‘settings-view’ package, and now my “Settings” don’t show anything and I can not manipulate packages at all anymore!


#10

You can reenable settings-view by opening config.cson (File -> Config...) and removing settings-view from the disabledPackages list.

Is there anything in your init.coffee file?


#11

I don’t find an init.coffee file.

I have now disabled all packages - community and core packages, and re-enabled settings-view, but still no tabs.


#12

It’s also under the File tab, and also lives in your .atom folder.


#13

I see. It’s empty.


#14

Hmmm, so if you run in safe mode you see the file tabs again but if you disable all community packages you don’t see the file tabs? Safe mode starts Atom with all community packages disabled and doesn’t run your init script (which sounds like it’s empty in your case) so it’s confusing why you don’t see the file tabs after you disabled all your community packages.

Also, you shouldn’t have to disable the core packages and in particular, the tabs core package has to be enabled to see file tabs. Can you confirm that the tabs package is enabled after disabling all community packages?


#15

Oh one more thing - was just reminded that after disabling community packages, make sure to restart Atom too.


#16

Ah, yes, forgot to tell that of course I kept the tabs core package enabled. Also I still had tree-view and settings-view still enabled.

But now to something more weird: I have rebooted my computer and then started Atom (still with everything disabled except the three aforementioned ones), and now my tabs are back!

I will now successively re-enable the packages and see whether at one point the tabs disappear again.


#17

BTW, I always restarted Atom after disabling packages. It looked safer to me to do it this way.

I have now reenabled nearly all packages, including the color-tabs package (which I had first suspected to be the culprit), and tabs are still to see - no problem anymore! There are three noticeable exception:

I had originally also the packages directory-color, line-number-color and rainbow-tabs enabled. When I enable them, I get now an error message

Failed to activate the directory-color package

document.getElementsByTagName(…)[0].append is not a function
Show Stack Trace
The error was thrown from the directory-color package. Atom is out of date: 1.16.0 installed; 1.23.3 latest. Upgrading to the latest version may fix this issue.

I am aware that I should update Atom, but I didn’t want to change the current setup while researching the problem.


#18

GOT IT!!! I did not pay enough attention to the fact that I had also switched the Theme before the error had appeared. While debugging the problem, I did switch the Theme back to what it was before, but since the error still persisted, I concluded that it can’t be related to the theme.

However, I have now learned that things went so weird that I had to restart the PC to get it back to “normal”, and now I can see that, as soon as a switch the theme to “City Light”, the tabs disappear.

I will update Atom to the new version. If the problem with the theme still exists then, I will open a bug report.

UPDATE: Updating Atom indeed solved the problem. It seems that the new “City Light” theme was not compatible with my old Atom version.