My dockable framework based on Electron


#1

Editor Framework comes out: https://github.com/fireball-x/editor-framework

I’m recently working on a dockable framework based on the Electron for our application. And here is a snak peak :smiley:

Docking a panel freely in the same window:

Docking a panel in different window:


#2

Looks great, I would like to use this. Is there anywhere I can follow for updates?


#3

I would also like to follow for updates! Great work so far.


#4

Currently it is actively developing, we going to public the repo for web developer very soon. I will reply on this as soon as it opened.


#5

Been 15 days, any update?


#6

Hi steelbrain,

You can check our roadmap here https://github.com/fireball-x/fireball/issues/3. Basically we gonna to release a sneak peak version of this framework in July, the dockable system is part of it — the Fireball Editor Framework. Right now I’m busy in developing the package manager for it.

One of our product is currently using this framework — http://www.fireball-x.com/en

Regards,
Wu


#7

https://github.com/fireball-x/editor-framework Just release the first version of editor-framework :smiley:


#8

I wanted to try out a demo of the editor-framework, but I’m having trouble getting it to work. (This is my first real attempt at doing anything with Electron, so I could easily be doing something wrong.)

First attempt: Clone fireball-x/editor-framework. Run npm install, as directed. npm install fails - it gets as far as the install-builtin Gulp task, but that gave me a permission denied error while trying to clone one of the repositories. (Unfortunately, I failed to make a note of which one.) npm+gulp+git’s prompts to confirm SSH keys were also not interacting well with my PowerShell window. To fix all of this, I changed the gulpfile to clone over HTTPS instead of SSH.

Second attempt: After getting npm install to work, the next step (I thought) was to run the demo. From the editor-framework local copy, I ran gulp run, but that didn’t work either:

[15436] Error: Can not find function “init” in your App

Third attempt: I thought that maybe I needed to download something else to get the demo. After poking around some, I found the web site (it might be nice if editor-framework’s repo linked directly to this). I hoped to find a nice simple “Download” link, but I didn’t see one; I did see a “Project Source” link under Demo, so I followed that. Here I ran into another problem: Project Source > docs -> step 1 (step-1.md) -> Get Fireball -> dead link.

I’m not sure where to go from here. Any suggestions?


#9

Hi joshkel,

I’ve provide a yeoman generator for people who wish to working with editor-framework: https://github.com/fireball-x/generator-editor-framework.

Based on your information, I think you are not setting right to your SSH in github, which lead to the npm install failed. Because I’m using ssh protocol for all packages used in editor-framework.

For the Error: Can not find function "init" in your App, I think I’ve fix it in recent updates. Just try the latest code for it.

Regards,
Wu


#10

You were right; I had an issue with my SSH key setup.

I deleted, re-cloned editor-framework, and re-ran npm install, and things are working now. Thank you very much for your help.


#11

Hi JWu,

I also am having trouble installing. Tried both through clone and npm install. In either case get “fatal: Could not read from remore repository. Host key verification failed.” Right after Cloning into ‘builtin\console’. This is on Windows (10). I guess this is some SSH thing - can you help here?

Thanks,

Aharon


#12

Hi ahaber,

There is an issue talking about it: https://github.com/cocos-creator/editor-framework/issues/184, I’m consider using https:// instead of ssh:// for git clone. Right now there is only some problem in windows platform for this. I gonna fix it soon.


#13

Why did you delete the whole repo out of no where?
Are you moving it somewhere else or what???


#14

@jfmmm LifeProTip: Do not use more than one question marks at once, they are rude and abuse :slight_smile:

If I had to guess the repository has been renamed, you can find it at https://github.com/cocos-creator/


#15

Good thing you don’t have to guess then… because that would be wrong.


#16

The designer of our company info me I don’t have the copy right of the style-sheet for this repo and must remove them out for copy right reason. So I can not public the repo with MIT license until I remove all UN-LICENSED things. So I have to close the repository for the commercial reason… :frowning:


#17

Oh wow a copyright on a stylesheet… damn :worried:.

Hope you find a way to resolve this and bring back that awesome tool.

Good luck!

I Wish I had updated my local version more recently, I was suppose to do this tonight :unamused:


#18

I am trying to delete all stylesheet and leave a barely dockable framework of it. I’ll do this as soon as possible.


#19

Any progress made?


#20

Not yet, I’m still working on the new features the company asked for. I have to start rewriting dockable module after that. In my schedule, it should be starting from October.