My development syntax theme won't install outside of dev mode


#1

In dev mode, the package is installed. Outside of dev mode it shows up under Development Themes, but when I click the Install button I get this message:

Installing “sideways-syntax@1.2.0” failed.
Request for package information failed: Not Found

This is a syntax theme I just forked on github here:


I cloned, edited the package.json for the new name and repo values.
This is my first time creating a theme. Thanks in advance for any assistance.


#2

Before you can install a theme from APM, you have to publish it.


#3

I just ran apm install minor from that directory and it is complaining about the repo field.
I used the url for a branch I forked from my own master, my fork of this theme. Is that the problem? It’s the path I used in the link in my original post: https://github.com/sidewayss/wombat-light-syntax/tree/sideways-syntax

Should I not branch my fork? I wanted a new name for the repo, and I’m used to managing sub-branches.


#4

I don’t see how to edit posts here. I meant publish, not install minor, as the command I ran. And it won’t let me reply without waiting…


#5

Yes, that solved it. Use the master branch and it works.


#6

You can do whatever you want with the branches, but APM is only going to be interested in what’s in Master, as far as I know.