My C++ program does not compile

I have done everything from installing gcc package and have installed minGW on my system and pasted the bin folder in the path .but something doesn’t seem right. Please someone help.

My advice - if you are starting out - is to launch just a terminal window inside Atom and go through your first coding exercise using only internal shell commands.

e.g. gcc --version

This will ensure that Atom can find all your compilers and other resources.

When you have completed some shell terminal only exercises you can progress some more steps with Atom.

2 Likes

How to open terminal in atom IDE?

  • Essential reading

  • Run this command in your OS terminal and report back the output
    apm list | grep terminal

  • Look for a + icon at bottom left status bar of Atom and click on it to launch a terminal panel.

You can search for packages in Atom or on this website. I usually recommend termination because it’s easy and not out of date.

Since @Abhinav mentioned MinGW, we know that they’re using Windows. Windows doesn’t come with grep by default, and it’s not a given that anyone who has installed MinGW will have installed grep (I have, but I’m also a Linux user so I know what tools are available).

Deferring to Windows environment …

apm list | findstr terminal

Just trying to reduce the bandwidth taken up in answering/guessing new users’ questions.

For example in Ubuntu there is an excellent script boot-repair which scans a user’s environment and creates a url to inspect this audit report in pastebin. The onus is on the user to make such information available to responders in forum.

Typical helpful information to scan automatically …

  • OS in use
  • packages installed
  • compilers installed
  • etc.

Might be helpful to suggest a list of useful external tools for such detective work.

Here’s the result :persevere:

When I run and compile C++ program. I get this error

What happens when you run atom --version from the command line outside of Atom? Take a look in the folder C:\Users\Abhinav K\AppData\Local\atom\ and see if you see a folder called bin\.

When I run and compile C++ program. I get this error

What happens when you use g++ --version from the command line outside of Atom?

Just an observation … paths containing spaces in user name “Abhinav K” (as in Windows) should be in quotes.

I have bin folder in C:\users\Abhinav K\AppData\Local\atom.

When I run g++ —version and atom —version it says atom and g++ Is not recognized as an internal or external command, operable

program or batch file

I am not a Windows user, but I suggest that you run the command echo $PATH and where you see the path to bin\ you should put this path (with current space in user name) in quotes …

"C:\users\Abhinav K\AppData\Local\atom\bin\"

Then commands such as atom and apm might be found in $PATH.

p.s. I see that there is also atom.exe outside bin folder so I’m not sure where atom.exe is actually run (again I’m not a Windows user). Reading further I now see that there is a file atom.cmd in the bin folder.

Here is a relevant discussion thread which I found (also with space in path).

Well, I want to close this topic here! I uninstalled MinGW and Atom IDE and reinstalled it! Guess what? It works like a charm! Thank you guys for supporting me in this topic so far! Appreciate it! :grinning::ok_hand:

1 Like

I wasn’t typing out a command string, just naming the folder.