Multi select with command D (osx) not working


#1

Hello, up until recently I was able to use command D to select multi lines. Suddenly I am no longer able to do this I see the following message in the top right corner of Atom

Can’t Navigate to (name of variable here)

Does anyone know how to fix this?
Thanks!


#2

Can you reproduce the problem in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

I have the same problem with @cmitides89 even in safe mode.
I appreciate any help.


#4

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.


#5

Thank you for your advice

I have tried before but the Keybinding Resolver just only can’t resolver the (Cmd + d)

I have also tried to add the keymap.cson but no luck

'atom-text-editor':
  'cmd-d': 'find-and-replace:select-next'

Finally, I have just changed the key from ( cmd-d ) to ( cmd-i ),…um… it works. but…:cry:

Sorry for my english.


#6

So what happens when you press Cmd+D?


#7

Oh~~
I found the problem.
I installed BetterTouchTool and accidentally added the hotkey (cmd-d) to do something else.
This is all my fault.
I’m sorry to have wasted your time.


#8

You didn’t waste our time. I’m glad that we helped get things figured out :grinning: