Mouse selection problem


#1

Hi !

From this morning I can’t select text with my mouse anymore in Atom.
However I can select text by keyboard or with Ctrl-A shortcut or with mouse in others applications.

Can you help me please ?

Thank you.


Cursor selection not working
Cursor selection not working
#2

Are you running Atom inside of a VM (virtual box or vmware)? If so you might be affect by the Chromium bug which has been introduced recently. See here:

and here:

https://code.google.com/p/chromium/issues/detail?id=456222

At the moment the only thing you can to is to disable mouse integration in your vmplayer by hitting HostKey+I or disable it at the bottom right corner of your vmplayer window (in case of virtual box).


#3

Yes I run atom in Manjaro (Archlinux) VM.

HostKey+I works for me !

Thank you :slight_smile:


#4

thanks. HostKey+I works for me too, but it is pretty annoying because I switch back and forth between host and guest a lot. I would like a better fix that doesn’t require HostKey+I


#5

Same here, I would like a better solution than Host+i, since the mouse speed will then be different too, and I’m already at the lowest setting in the VM.


#7

This problem was supposedly fixed in Chromium on May 21, but Atom still contains the bug. My preferred OS is Windows, but programming is generally easier in Linux, especially when working with Ruby, so I use a Debian VM… but this bug is pretty annoying and I have to choose between not being able to select text, using a different text editor, or deal with clumsy OS switching.

It seems that simply updating the Chrome version would fix the bug (from what I can tell, Atom uses Chrome 41, while the bug appears to be fixed in Chrome 43.)


#8

If you feel you can assist with this process, the Pull Request to do exactly that is right here: