Mouse is Highlighting Text by Only Moving Mouse


#1

I got a new mouse today (Logitech, m705). It seems that whenever I’m in Atom and I click a line to go to, whenever I move my mouse, it highlights wherever my mouse goes to. When I go into the editor, my click should only just place me into the line I want to go to. When I move my mouse out of the way, it should not highlight anything - but this is not the case.

Please note, I’m not holding my mouse down nor have the shift key pressed down.

If I need to clarify the behavior, please let me know.

I was operating in Atom 1.40 when I noticed the behavior. I updated to the latest stable version, 1.5.4. But it’s still happening. My OS is Ubuntu 15.04.

Does anyone have any ideas on how to remedy this?


#2

Have you tried running atom in safe mode? Start on the command line with atom --safe.


#3

It’s doing the same thing.


#4

OK, the second standard advice is to close all windows, delete or rename ~/.atom and restart. If that doesn’t work do that but also reinstall before restarting. If that doesn’t work then post an issue on atom/atom.


#5

Thanks! I’m not sure why restarting my computer didn’t cross my mind… But I did that, and it seems to be working as expected now. If it’s ever re-occurring, I’ll post the issue.


#6

I don’t know if you are a fan of the british show The IT Crowd (you should be) but the IT guy at the company plays a recording of “Have you tried turning it off and back on” to every call. I should have asked that.