Mouse drag in Ubuntu?


#1

I installed Atom on Ubuntu 15.04 x64, if that makes any difference it’s in a VM using VMWare Player.

Everything seems to work fine except that Atom (and nothing else on the system) fails to handle mouse dragging events. Whether I try to select some text, move a scrollbar or resize the tree pane, it’s simply ignored…

Anyone knows what I could do about this?


#2

@thomasjo Were you the one that said there’s some sort of issue with Ubuntu in a VM?


#3

Hmm, not that I can remember, at least not related to this specific issue.


#4

Does Chrome exhibit the same symptoms in this environment?


#5

Yep, Chrome and Chromium have the issue, apparently they think the mouse is a touch device…


#6

Ok, I’ve fixed it!

$ xinput list

Virtual core pointer                    	id=2	[master pointer  (3)]
  ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
  ↳ ImPS/2 Generic Wheel Mouse              	id=10	[slave  pointer  (2)]
  ↳ VMware VMware Virtual USB Mouse         	id=8	[slave  pointer  (2)]
  ↳ VMware VMware Virtual USB Mouse         	id=7	[slave  pointer  (2)]
Virtual core keyboard                   	id=3	[master keyboard (2)]
  ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
  ↳ Power Button                            	id=6	[slave  keyboard (3)]
  ↳ AT Translated Set 2 keyboard            	id=9	[slave  keyboard (3)]

For some reason, one of the VMWare mice was causing the issue, while the other allowed Ubuntu to detect the back/forward button on my mouse, I had to disable them separately to figure out which one it was.

In the end, the following command did the trick:

xinput --disable 7

Thanks for pointing me in the right direction!


#7

I have the same issue in ubuntu 14.04 64bit running as a VM under Hyper-v. chromium and atom think the mouse is a touch device. However the xinput shows this:
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Microsoft Vmbus HID-compliant Mouse id=7 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=6 [slave keyboard (3)]

and disabling the id=7 mouse, disables the mouse altogether , while id=4 cant be disabled…
Any other idea? Thanks in advance,
hans

I did some more research and it looks that this is relation to this issue in chromium:
https://code.google.com/p/chromium/issues/detail?id=456222#c155

Starting chromium with the --touch_devices=123 flag solves the problem for chromium. So, how would one pass this flag to atom? Or is that not possible?


#8

I’m currently running a Ubuntu VM (14.04 x64) running on VirtualBox (4.3.28 r100309)

As @hansrwindhoff this issue seems to be related to:
https://code.google.com/p/chromium/issues/detail?id=456222

The same behaviour is exhibited.
A fix has been implemented and available in Chromium since 43.0.2357.65

Is a Chromium version bump expected in Atom any time soon? (currently running Atom v1.0.0)
Or is there a way to run Atom with the Chromium flag --touch-devices=123 as a temporary work around?

This unfortunately makes Atom rather unuseable
Will be switching back to Sublime Text in the mean time.


#9

Update: After the latest rounds of Ubuntu updates, I had to reinstall VirtualBox Guest Additions. This seems to have corrected the issue.

All seems to be well now.