Mouse clicks stop working in the editor


#1

I’m seeing this now in 0.123, but it’s been there for at least the last couple of versions. At some point mouse clicks stop working in the editor (to reposition the cursor). I can still move the cursor via the keyboard. Restarting Atom fixes it.
I haven’t been able see any pattern to this – sometimes I work for hours without seeing it, sometimes it happens almost immediately after I started editing. Not doing anything unusual that I can see when it occurs.


#2

I’ve seen this occasionally too. What fixes it for me is switching from the current tab to another tab and back. Much faster than exiting and relaunching.

I don’t have a repro for it though, so I haven’t filed an Issue on this yet.


#3

Thanks for the tip on switching tabs! That will save some time…


#4

I’ve got another trick, using the alt key seems to fix it as well, less painful than switching tabs. Tell me if it works for you, it could be interesting to find the origin of the problem.


#5

I will – so far haven’t seen the issue today…


#6

Finally had this happen again today – @abe is right – clicking while pressing the ALT key also fixes the problem.


#7

This issue is really driving me nuts, I think it has something to do with react but I’ve got no evidence yet. I always end up quick switching with CMD+ALT+LEFTARROW / CMD+ALT+RIGHTARROW


#8

This issue has gotten somewhat worse for me in .124 - seems to happen more frequently, especially on longer files (2000+ lines), and neither of the previous workarounds are working for me now (switch tabs or ALT-click). As of now, my only workarounds are relaunching Atom or selecting some text at the point I want to go to and then using the cursor keys (right or left).


#9

Are you by any chance using “Sublime Style Column Selection”? It has a problem that gives this symptom.


#10

I am indeed. Thanks for the tip!


#11

Is this the Issue you’re referencing @mark_hahn?


#12

Not to answer for @mark_hahn but I believe so. Disabling Sublime Column Selection fixed the issue for me, and indeed ALT-Tab turned out to be the trigger for the issue for me at least.


#13

I don’t know if anyone got that too, but I frequently get this issue after opening the devtools.


#14

Yeah, I’ve disabled the package as well. We’ll see how it works out for me today.


#15

No. I never use alt-tab. My problem with it is that at random times it acts as if the alt key is stuck down. The only way to clear it is to do a column selection one or more times. I posted an issue a long time ago.

The mouse clicks are actually working. It appears broken because the mouse only does anything if you drag to make a column selection. You can click and double-click and nothing happens.

The problem is so bad I keep the package disabled and enable it when I need heavy column selection. I need it so much I keep the settings tab open with that package selected on the left.

I am intending on working on the problem but I keep putting it off.

BTW, the author acknowledges similar problems when you drag the mouse out of the window and let go. The alt key seems stuck then also. This is a common problem on web pages but I have fixed that problem several times. I know that isn’t the cause of the big problem.