Module version mismatch


#1

Hi, I’m trying to include “Pocketsphinx” into an atom package project, but every time I activate the package after including the library I’m getting “Module version mismatch. Expected 49, got 48.”

Could you please help me solve this issue? thanks.


#2

Have you tried running apm rebuild from the root of the package directory? That will rebuild any native dependencies of your package. Typically the module version mismatch message is received when native dependencies of your package were compiled for a previous version of Electron, the application framework Atom is built upon.


#3

Thank you @leedohm for you reply, I tried to execute apm rebuild but unfortunately it didn’t work, do you have any other suggestion, please?


#4

Have you tried to remove node_modules and npm install it again?

I had the same problem lately and I’ve run apm_rebuild and it didn’t work, then I updated my package (Electron and some random others packages, because I didn’t know where is the cause) in package.json and after maybe third time when I ran npm install and apm_rebuild it just started work.

(but I had no bloody idea what I was doing, whatsoever).

"Module version mismatch. Expected 49, got 48."
had this when I tried to use git-utils package, then after my NPM voodoo it changed to “Expected 50, got 49”, and then it fixed itself.


#5

Thanks for your response, actually I tried everything to include this library in my project but it didn’t work, so I found another one now and I’m working on it, thanks again :slight_smile: