Missing Editor (only shows dev tools)


#1

I just downloaded the Atom application. When I start the application I just see a “dev tools” window and nothing else. Seeing as I have not done anything to customize and therefore mess it up (yet), how can the default download be so broken for me?


#2

Did you use the Archive Utility? Or did you decompress from the command line with the unzip command?


#3

I used Archive Utility since it auto extracted


#4

Well, you can always give us more information because I haven’t seen or heard of this happening on a brand new install:

  1. What version of OS X are you running?
  2. Can you give us a screenshot of what is happening?
  3. What model of Mac are you using?
  4. How much RAM do you have installed?
  5. Did you have Node.js installed before you installed Atom? If so, what version?
  6. Where did you launch Atom.app from?
  7. Do you have access to another Mac to copy the app to and try to run it there?

Hopefully one of those should help.


#5
  1. OS X 10.9.2
  2. Screenshot: https://www.dropbox.com/s/t5erztguunt88p1/Screenshot%202014-04-10%2020.02.10.png
  3. Mac Book Pro (late 2013): https://www.dropbox.com/s/smn2qpne8fo24ke/Screenshot%202014-04-10%2020.03.26.png
  4. 16 GB
  5. I have not installed Node.js
  6. I originally started it from “Downloads” then from a “tmp” directory at my user’s home directory
  7. I do not have access to another Mac. :frowning:

#6

Dev Tools Error: https://www.dropbox.com/s/mi18keaa3vn1x4z/Screenshot%202014-04-10%2020.06.45.png


#7

Clicked around a bit more, the error I was seeing is the following line of JavaScript.
require(“coffee-script”).register();

And the error in DevTools is the same as the image above.
TypeError: Object # has no member ‘register’ at window.onLoad(…/Atom.cpp/Contents/Resources/app/static/index.js:18:30)


#8

Can you put the Atom.app file into /Applications and try it there?


#9

Moving the Atom to the Application folder fixed it.

Thanks.


#10

You’re welcome! Glad I could help :grinning: