Missing atom.exe


#1

I can’t open/view files with atom from the windows right click menu because it says that I am missing atom.exe. I have searched through my entire computer and never found it. I found AtomSetup.Exe instead. The only way I am able to use atom and open/view/edit files is that I open the atom editor first then choose to open from the file menu.

I have no idea what could have made the atom.exe file to disappear but I have uninstalled and reinstalled the atom few times. It hasn’t changed anything.


Missing AppData\Atom folder
#2

Sounds like the registry entry for Atom’s context menu command has been corrupted.

In Windows, there is an atom.exe in each version’s folder, but the command in your right-click menu should not point at it because then it won’t work when the app gets updated:

So what you want is for that command to point to a location that doesn’t change, which is why there is a command file in the bin folder. Every update just changes which version the .cmd file points to:

My guess is that the version your right-click Atom command pointed at was removed. And for some reason it hasn’t been updated by subsequent installations.

If so, you’ll probably have to update the registry, finding the right key to modify.


#3

Also… My thickness knows no bounds today. Quickly hurries to remove questions which OS is being used while noting where to find atom.exe.


#4

I followed the path that you had suggested, but there is absolutely nothing in those folders. However I do have this Users > jmoakey > .atom, not under Users > Public > AppData .


#5

The .atom folder in your user’s home directory is not where the application is installed. It’s where Atom stores packages and settings.

What do you have under the C:\Users\[username]\AppData\Local\Atom folder then?
Did you not use the normal installer, but something like chocolatey or the zipped folder?


#6

I did use Chocolately originally but then I uninstalled that. I can’t recall when it stopped working. I noticed it one day but I don’t code as much as I used to but lately I got put on a project and I have been using it and it didn’t bother me at first, mostly because I was busy at the time but then it became annoying.

I literally do not have AppData in C:\Users[username] Just in C:\Users\Public and the path follows as above except there is no Atom folder in there


#7

Ah, AppData is hidden!
You’ll have to either cd into it from command line or change your folder options to show hidden files.

Sorry, I could have mentioned that.


#8

Or just type %APPDATA% into Explorer’s address bar.


#9

Ah-ha! Found it! It’s working now. Thank you so much for your help!! :smiley: :smiley:


#10

You’re welcome.

:ok_hand:


#11

Hmm. I am pretty sure I didn’t update Atom.

Anyways suddenly all of my Atom shortcuts are now pointing to ‘Update.exe’

C:\Users\username\AppData\Local\Code\Update.exe --processStart atom.exe

I can resolve but how to prevent in future?

Does Atom auto update?


#12

@genoki What Atom version are you running now?
Also, are you sure about the Code folder? That should be atom.


Windows 10 defender atom.exe malware
#13

That was path in my shortcut. i changed it to

C:\Users\username\AppData\Local\atom\bin\atom.cmd

looks like i have version “app-1.0.4” now

Weird.


#14

Looks like your shortcut just wasn’t updated when Atom updated itself.
But pointing to the atom.cmd file instead will always open the latest version you have installed.


#15

How I solved the problem in version: 1.10.2

Atom SETTINGS -> System: tab -> Checked two options:

  • Sow in file context menus
  • Sow in folder context menus

(Probably an update has changed/added something.)


#16

Yes, this is a brand-new feature in v1.10.x:


#17

I solved by editing these two values in the registry to the proper atom version…:
HKEY_CLASSES_ROOT\Directory\Background\shell\Atom
HKEY_CLASSES_ROOT\Directory\Background\shell\Atom\command
HKEY_CLASSES_ROOT\Directory\shell\Atom
HKEY_CLASSES_ROOT\Directory\shell\Atom\command


#18

↑ Thank you marians, this was the fastest and easiest way to fix it