Minimun requirements electron releases


#1

Hi,
first of all congrats! I really love electron, very useful development. I´m looking for official info about operating system requirements and will be awesome if you publish it. Now I´m developing an app for Windows OS using node v0.29 and I wonder what happens if I use win32 release in 64bits OS with 1GB memory. Or what happens if I use applets in this app, should I configure windows system?
Anyway this kind of info will help most of us to continue growing with electron.

Thanks in advance,
Alberto


#2

What sort of system requirements are you looking for?


#3

I mean, will be great you publish info about minimum requirements for all architectures (linux, win and OS X). Will be great:

  • System memory requirements.
  • NPAPI plugins allowed (applets…)
  • OS configuration, will modify app behaviour? i.e. Java parameters
  • Minimun OS versions (Win7, OS X 10.9, linux…). Deployment and running apps.
  • OS language will affect apps?

Thanks in advance,
Alberto


#4

It’s an application framework, so a lot of what you’re asking is up to how you build the application. I think the only one of the questions you gave that can be answered with any finality is the minimum OS version which is OS X 10.8 or higher, Windows 7 or Server 2008 R2 or higher and who really knows on Linux :grinning:

Disclaimer: I am not an employee of GitHub nor a member of the Atom core or Electron teams. The above should not be considered “official”.


#5

Thanks,
I agree with you, anyway in my opinion, tech info is always welcome and help new developers to start or choose this framework.


#6

Just FYI, I’ve done some testing of a reasonably simple electron app on different machines.

Lowest spec machine I’ve tested on is a Windows 7, Core 2 Duo with 4GB RAM and a mechanical hard drive. It ran perfectly even with a number of other apps open. I then physically removed 2GB of RAM and rebooted, the app ran ok on its own but as soon as I opened a few more apps it became noticeably sluggish.

Anecdotal of course and based on one test but I would say 2GB RAM is the bare minimum for an Electron app. The minimum specs for 64-bit Windows 7 and OS X 10.8 are 2GB RAM anyway so it’s reasonable to just specify a minimum OS and ignore the rest of the specs.


#7

Thanks @davej, useful info :ok_hand: