Minimap plugin doesn't display with React editor


#1

Atom: v0.107.0
Minimap: v1.4.0

My history was TM, ST2, ST3, Atom, ST3 and I’d just come back to Atom after finding this plugin (which was one of the things I missed).

Now, I’m stuck between slow editing speed or the minimap…

Can anyone recreate just so I know I’m not going mad?


#2

Have you considered filing a bug or contacting @fundon?


#3

Didn’t know what the process was about filing bugs, should this go to Atom - or to Fundon? at-including people in comments is nice in Discourse (never used that before - very cool).


#4

It’s a known issue, see here, not easy to fix though. In practice, it requires a complete rewrite and I didn’t really had time to look into this. I don’t know about @fundon workload, but I wouldn’t expect a react-compatible version quickly.


#5

Generally, if you have a bug for a package then you should file it on the package. You can find a link to the Issues page for a package on the package’s page on http://atom.io:

But Discuss is a great place to ask questions about these kinds of things :grinning:


#6

The support of React-based editor just landed in v1.5.0. There’s still some issues to address (I get some errors from time to time) and optimizations to do (it don’t use React like the ReactEditorView), but it’s at least a first step :).

Note that I also have updated all the plugins that were breaking as well when the React editor was enabled.


#7

It’s back working for me. I did just get an Inspector Error, but it doesn’t happen often, so I’m pretty much happy again :slight_smile:


#8

Just opened Issue no #98 for this package.
The minimap covers the right scrollbar, in my Windows build with React editor enabled at least.

Nice work so far!


#9

Just opened issue #100 - using the Find | Select All command (from the keyboard, but I can’t type a command key) generally pops open the Inspector with the console showing an error in Minimap 1.5.2 and React editor.