Minimap package not installing


#1

Hello i am trying to install the minimap package but it is coming up with errors, can anyone help please!

> npm http GET https://registry.npmjs.org/prolixindent preformatted text by 4 spaces
> npm http GET https://registry.npmjs.org/semver
> npm http GET https://registry.npmjs.org/delegato
> npm http GET https://registry.npmjs.org/emissary
> npm http 304 https://registry.npmjs.org/emissary
> npm http 200 https://registry.npmjs.org/semver
> npm http 200 https://registry.npmjs.org/delegato
> npm http GET https://registry.npmjs.org/semver/-/semver-2.3.2.tgz
> npm http GET https://registry.npmjs.org/delegato/-/delegato-1.0.0.tgz
> npm http 200 https://registry.npmjs.org/prolix
> npm http 200 https://registry.npmjs.org/semver/-/semver-2.3.2.tgz
> npm http GET https://registry.npmjs.org/prolix/-/prolix-1.0.2.tgz
> npm http 200 https://registry.npmjs.org/delegato/-/delegato-1.0.0.tgz
> npm http 200 https://registry.npmjs.org/prolix/-/prolix-1.0.2.tgz
> npm http GET https://registry.npmjs.org/underscore-plus
> npm http GET https://registry.npmjs.org/property-accessors
> npm ERR! not found: git
> npm ERR! 
> npm ERR! Failed using git.
> npm ERR! This is most likely not a problem with npm itself.
> npm ERR! Please check if you have git installed and in your PATH.

> npm ERR! System Windows_NT 6.2.9200
> npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.119.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.119.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.119.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Caino\\.atom\\.apmrc" "install" "C:\\Users\\Caino\\AppData\\Local\\Temp\\d-114628-6648-1np9741\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2010"
> npm ERR! cwd C:\Users\Caino\AppData\Local\Temp\apm-install-dir-114628-6648-10gdq01
> npm ERR! node -v v0.10.26
> npm ERR! npm -v 1.4.4
> npm ERR! code ENOGIT
> npm http 304 https://registry.npmjs.org/property-accessors
> npm http 304 https://registry.npmjs.org/underscore-plus
> npm 

#2

Did you see this part?

> npm ERR! not found: git
> npm ERR! 
> npm ERR! Failed using git.
> npm ERR! This is most likely not a problem with npm itself.
> npm ERR! Please check if you have git installed and in your PATH.

#3

yeah, i do have git installed but how do i put it in my path please
(its my first time adventuring outside of software like dreamweaver)


#4

@batjko Can you help out here? I’m not familiar with the canonical way of configuring Git on Windows.


#5

Best and easiest way to install Git on Windows is, in my opinion, to use Chocolatey:

Once Chocolatey is installed, simply run cinst git and you’re golden.


#6

It looks like you have Chocolatey already installed, but it cannot find your Git (I didn’t actually think that was a prerequisite???).

Anyway, so for now you can add your git executable (the path to git.exe) to your environment path, something along those lines:

e.g. Windows 8:


And then add the path where your local Git installation has its git.exe to the system PATH variable.
Like this (a bit convoluted, but I hope it makes sense):

Edit:
Ok, so the above assumes you have Git installed but not added to your PATH, which happens often on Windows.

However, if you don’t have Git at all, I suspect Chocolatey hasn’t been installed properly, so re-install that first in this case.
If Git is still needed for some reason, install Git for Windows and make sure to add it to the path as described above…


#7

When Git is installed via Chocolatey, the PATH is configured automatically. No need to manually set environment variables.


#8

Yea that’s what I thought. So presumably something went wrong with his choco installation, or there was a Git installation previously and choco messed with it somehow…

Re-installing the Choc monster from scratch may be best.


#9

Why are we assuming he has installed Git via Chocolatey? Did I miss something? :smile:


#10

No no, my assumption was only that Choco couldn’t find a git installation, i.e. what the error says.

So we’re just thinking of ways to solve that. Whether or not that will directly fix any issues with installing Atom, we’ll see.


#11

Chocolatey is only a package manager; it doesn’t try to find anything. It’s apm that’s failing to find the main git executable. If @RyanCain doesn’t want to use Chocolatey to install and manage Git, then he should follow your previous instructions regarding setting up the PATH environment variable.

I strongly recommend using Chocolatey to easy future upgrades and what not. Package managers rock! :metal:


#12

Thank you all so much for all of your help it was batjko who’s post helped me, it wasnt pointing to git.exe, so again thank yous so much for all your help, this has to be the best forum that i have been on :smile:


#13

I had the same issue, but although my git path was set it was pointing to the cmd folder. Updating the path to point to bin fixed the issue. Kind of confusing because both folders contain git.exe files…

C:\Program Files (x86)\Git\cmd;

change to:

C:\Program Files (x86)\Git\bin;

That fixed the issue for me.


#14

I had long the same problem. This same procedure cited by rvarbanov solved my problem. What happens is that it does not work if installed manually. Must be installed via installer Atom packages to work. You can also simply add the path to the bin git beyond the cmd as the windows also need the cmd path to function properly


#15

Can someone please explain to me why Minimap requires Git to be installed to install?

I mean, I have Git installed on my dev boxes, so that’s not a problem, but I also have Atom installed on some test machines and I’d rather not have to put anything else on there just to get Atom/Minimap to work?


#16

@abe, can you answer @DMLou’s question? I suspect it has to do with one of minimap’s dependencies … but I’m not sure.


#17

It depends on property-accessors that itself depends on harmony-collections which is defined as a git path in package.json:


#18

Wow, this post should be at the frontpage. What a simple solution to a common problem! I don’t understand why git is part of the dependencies.