.md file and single quote [Resolved]


#1

Dear all,

I am a quite new and quite happy too Atom user.
Nevertheless, I encounter a problem within .md files.
When wrinting normal text, single quotes are often used (e.g. don’t or John’s role…). And it unfortunately leads Atom to change the text color … until de next single quote.
Is there soemething I can configure to avoid this ?
Note that I am using One Dark UI Theme with Base16 Tomorrow Dark Sntax theme.

Thanks for your help
J-L


#2

I just tried with a couple of other syntax theme and the behavior is the same.


#3

Hello, welcome to Atom.

I cannot reproduce what you are describing. Could you please paste your broken text here, so someone can take a look? Be sure to select the block and click the </> button once you paste it.

Alternatively, wrap it in backticks like shown

```
<paste it here>
```

Incidentally, you aren’t using backticks are you? Because they have special meaning in markdown and could be the cause of your problem.


#4

Thanks for your answer.
Indeed, it is not backticks. It is actually single quotes. And when there are on purpose backticks, they are interpreted as they should.
It can be illustrated with the example below :

Waiting for host is available through the [`wait_for`](https://docs.ansible.com/ansible/latest/wait_for_module.html) module.
Let's say that we want to wait for port 22xy to be available as a wait condition. But as the stop operation and the start step both take some time, let's consider a `delay` before starting to wait.

On this example, wait_for and delay are correctly written (monospaced), but the text after Let’s is rendered (on the editor pane) as if it was a code block. And it goes back to normal text on the next single quote.
Note that the presence of some backticked words is out of the picture. The same behavior is observed even without such words.

Nevertheless, it is not that critical as it only affects the editor panel. The text display (markdown preview, whatever the chosen style is correct. But it is a little bit annoying.


#5

This is what I see. Checking the scope between the single quotes (using Editor: Log cursor scope in the command palette) shows no scopes are being applied to between the quote marks.

I’m guessing you are not using the built in language-gfm package as your markdown scoper. Could you please tell me which package is providing the scopes? This is normally one called language-<something>.


#6

Thanks for your quick reply :slight_smile:
I am using the language-markdown 0.25.1 package.
So, I have tried to install language-gfm and even language-gfm2.
That’s exactly the same behavior…
Here is what I found with language-gfm2 enabled for Log Cursor Scope.

Scopes at Cursor

source.gfm
markup.code.shell.gfm
source.embedded.shell
meta.scope.if-block.shell
meta.scope.if-block.shell
meta.scope.subshell.shell
meta.scope.for-in-loop.shell
meta.scope.if-block.shell
meta.scope.if-block.shell
meta.scope.if-block.shell
meta.scope.for-in-loop.shell
string.quoted.single.shell
punctuation.definition.string.begin.shell

#7

I am using the language-markdown 0.25.1 package.

You may have had language-markdown installed, but I don’t think you were using it.

So, I have tried to install language-gfm and even language-gfm2.

I’ve never heard of language-gfm2, but language-gfm is built in to Atom, so there was no need to install anything extra.

Here is what I found with language-gfm2

That output is extremely weird. Is there more to the file that you haven’t shown? Try opening Atom in safe mode (run atom --safe in the command prompt) and seeing what happens in the file. If you are using the proper markdown extension .md, markdown highlighting from language-gfm will be automatically applied.


#8

Ok… I have removed language-gfm and gfm2…
And now, all is OK.
I think something was wrong in my configuration.
For information, the Log Cursor Scope is now much more simple :slight_smile:
Scopes at Cursor

source.gfm
markup.code.shell.gfm
source.embedded.shell
meta.scope.group.shell
meta.scope.group.shell

So, never mind. Thanks a lot for your help. I really appreciate :slight_smile:.

Best Regards
J-L


#9

I still don’t know why you have a markup.code.shell.gfm scope in there. The text you posted does not have anything related to that in it.


#10

Well, don’t worry… perhaps it is because I have some sh or bash block such as :

 ```bash
export VAGRANT_LOG='info'
export VAGRANT_HOME='/cygdrive/c/Users/${USER}/.vagrant.d'
export VAGRANT_NO_COLOR=1
export VBOX_USER_HOME='/cygdrive/c/Users/${USER}/myData/VM'

#11

Inside the bash block, text is supposed to be highlighted. Is any text outside of the block getting highlighted?


#12

Thanks all for your help. I think that now, all is OK.
Texts are correctly highlighted when adn only when they have to be.

Thanks again and best regards !
J-L