Markdown preview not showing up


#1

Just tried Atom the first time and installed most of the markdown packages available. When editing a file (e.g. README.md) whatever I try the preview window does not show up. It should by clicking Ctrl+Shift+M (package “Markdown Preview”) or Ctrl+Shift+X (package “Markdown Preview Plus”). How can I solve it?


#2

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.


#3

Thank for the tip. I tried now. However, the output is probably as it should be: “Key Binding Resolver: ctrl+shift+M
markdown-preview: toggle …” still without the preview window being available.


#4

Can you post a screenshot of what you see? Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#5

Screenshot:

Atom Version 1.3.2
OS Suse Linux (Kernel 4.1.13-5-default)
No Emmet installed (do I need it?)
When starting atom --safe, there is a preview window opening up; however, it is not really transforming the markdown into the expected result. Since I am a new user I can only post one picture per post. So I will be adding a screenshot in the next post after this one.


#6

See attached screenshot.

OK, just installed emmet for testing. Key-Shortcuts do overlap. Desinstalled emmet again.


#7

leedohm mentioned Emmet because it seems to cause problems to Atom users (like some shortcuts / keys not working after a while, IIRC a post I saw here). Note I think it was also a culprit in Brackets, where sometime I could no longer enter a newline.

Note that some shortcuts are designed for a US keyboard. For example, I could not type the ] or } characters on my French keyboard, because they must be reached via AltGr shortcut which corresponds to Ctrl+Alt (the right ones, but I think Atom cannot distinguish them). So I installed the keyboard-localization package to fix that…

Note that you can reach the Markdown preview via the Packages menu item: you can toggle the view from there.
Another trick: open the Command Palette (via the View menu, last entry, or use the shortcut key it shows), and start typing Markdown. It should show the command to toggle the previews.
Another access: in Settings, Keybindings, also type markdown. You should see the various key bindings of your packages. You can change them in the keymap.cson file.


#8

The shortcut ctrl+shift+M is the same on a us or e.g. french or german keyboard.

It makes no difference on whether I use the shortcut or go via packages menu item / command palette. If this is really a problem it would be a bug - other users would have it too, right? I installed it as well on a mac os x notebook which shows the same behaviour!?


#9

@PhiLho was correct, I mentioned it because it has been the culprit behind many strange problems, especially where key bindings have been involved.

I cannot reproduce this behavior using Atom v1.3.2 on Mac OS X 10.11.2. Have you tried uninstalling the markdown-preview-plus package? The markdown-preview-plus install instructions state to disable the markdown-preview package:

So it would appear it is specifically designed to not coexist with the built-in package.


#10

I uninstalled Atom again, removed .atom - directory from $HOME and reinstalled it again. Now it is working. There seems to be a problem with some of the other markdown packages I did have installed, like markdown-folder, tidy-markdown, markdown-writer, markdown-pdf, language-markdown, markdown-pdf, markdown-writer, for instance. I don’t think it was markdown-preview-plus.

If I find out which of the packages caused the problem I will post it here.

Thanks everyone who helped me!!!


#11

You should learn carefully.It is a stupid error ----
# sapce
## space
### space
#### space
#sapce
##space
###space
####space
Did anyone note that
#No sapce
##No space
###No space
####No space
#No sapce
##No space
###No space
####No space


#12

That’s a good catch, I know it’s certainly caught me out before…

Can also confirm that it’s the expected formatting displayed in the preview.


#13

Here’s how I fixed Markdown not working.
It was a conflict with the Emmet package.
I found out that this was a conflict using cmd + . keyboard shortcut
That let me know that in the file ‘emmet.cson’ there was a conflict with ctrl-shift-m that is used to merge lines.
I don’t use that in emmet so I just commented it out (placed a # at the beginning of the line)
It still didn’t work.
I shut down atom and restarted and then ctrl+shift+m showed a preview of markdown.