Markdown preview behaving oddly


#1

1st post.(Very) New user

I’ve installed Atom on 2 Win 7 64 bit machines and one PC, shows the preview window fine, the other when CTRL + SHIFT + M is hit, opens Mailwasher?

I’ve CTRL + SHIFT + P and entered Markdown, it shows as CTRL+SHIFT+M which is right but for the fact Mailwasher opens!

I’ve checked Settings > Keybindings and CTRL+SHIFT+M has this in it

“ctrl-shift-M markdown-preview:toggle Markdown Preview atom-workspace, atom-workspace atom-text-editor”

As a new user I do not know what this is but it does not look right to me.

I browsed a few posts and saw some mentions of the keybinding file (empty) and someone said try this in the keymap.cson file
’.editor:not(.mini)’:
‘ctrl-shift-M’: ‘markdown-preview:toggle’

That does not work either. Can anyone suggest anything for a new user?
I can’t check the settings on the working machine until Monday, so I’m stuck for now
Thanks.


#2

Atom can’t react to keybindings if the operating system intercepts it before it gets sent to Atom. There are many utilities on various platforms that register OS-wide keybindings, it would seem that Mailwasher is one of them. This prevents Atom from being notified when the key combination is hit and prevents Markdown Preview from being opened. In order to fix this, you’ll have to configure Mailwasher to use a different keybinding. There’s nothing Atom can do about it.


#3

Hmmm, I did sort of wonder if that was the case. Looks like a post to Mailwasher then. Thanks for the pointer.