Manually install package?

How can I manually install a package? I have a fairly aggressive proxy, which is preventing the normal installer from working.


If you check the settings you can identify the folder in which packages are installed. I would guess a manual install is about as easy as extracting the latest repository release zip into that folder…?

The repo can be found via the “Learn More”-button in the package manager.

1 Like

You can download the package, unzip or decompress, go to that folder and run: apm link that will create a symbolic link from that package to your ~/.atom/packages folder.


I have the package (pretty-json) unzipped in my ~/.atom/packages directory. However, after restarting the Atom, the package doesn’t appear to be running. Am I missing something?

did you use apm link?

1 Like

I did. It returned this response:

> Linking ~/.atom/packages/pretty-json to ~/.atom/packages/pretty-json failed: EEXIST, file already exists '~/.atom/packages/pretty-json'

Unfortunately, when I press Command + Shift + P, the “pretty json” feature is not present.

Maybe you should run npm install in the decompressed package.
Works for emmet

You unzipped it into some other folder than ~/.atom/packages/pretty-json, right? If so, I would try to delete ~/.atom/packages/pretty-json and try again.

BTW, I thought we were supposed to use apm install, not apm link. Install will also load dependencies. I don’t know what other, if any, differences there are.

1 Like

This is a really old topic. Judging from the commit history, real proxy support didn’t exist in apm until the 16th of May … a few days after the last post on this topic. If I were recommending a strategy to someone working with apm now … I would suggest they try the proxy support as described in the README on the apm repository:

Yes. leedohm is right. It works fine on my setup.

$apm -v
apm  0.111.0
npm  1.4.4
node 0.10.33
python 2.7.3

you should open that path in terminal, and run

npm i

install the deps packages

You should never use npm to install or maintain an Atom package. While it worked in some cases historically, it is working in fewer and fewer cases as apm diverges from npm.

Also, manually installing an Atom package is generally a bad idea for the same reason. The process to manually install was simple at one point, but it is getting more complex as the needs of Atom grow.

you’re totally right AbeEstrada! Thankyou very much!

This problem also happened with my company computer, this is how I did to manually install a new package or theme:

  1. git clone the package repo into ~/.atom/packages
  2. cd into the package directory
  3. type npm install
  4. restart atom
    Everything worked normally except I need to manually update or delete a package :slightly_smiling:

What you’re doing by following the above instructions is the same thing you could do in one step with the apm develop command. Also, apm develop would do the job better and be future proofed against changes to how packages are installed … the above instructions are not.

Also, step #3 should be apm install. The apm and npm utilities are related but not equivalent (as I said above). If replacing apm with npm works, it is only a coincidence and probably will not work in all situations and will work less and less in the future.

1 Like

Actually, I don’t know what is the exact problem, may be Firewall or Security policy, but apm didn’t work on my company computer. It always lead to SSL problem, I tried to modify the file .apmrc to set SSL to false by strict-ssl = false but the problem didn’t disappear so I have no way except to install manually with the command above.

Well, almost every package worked until now, nearly 20 new install :slightly_smiling:

Thanks, it helps me a lot.

I use git clone + npm install, it works fine, however when I manually downloaded the package and move it to packages/ folder then apm install, it didn’t work.

I don’t understand. The apm develop command takes a <package_name>, not a Git URL, so it clones from the original Git repository. Yet the package maintainer has told me to fork the repository and submit pull requests from that. So how would I install a package from a forked repository into Atom for testing and development?

Plus I don’t understand what the apm develop command does. Yes I see that it has cloned a repository, but it didn’t link it to ~/.atom/packages, it links it to ~/.atom/dev/packages.

I later realized that the package shows up in a separate area in Atom, under “Development Packages”, but I don’t seem to get any key bindings. And I don’t see any commands with Ctrl+Shift+P. Is that normal? I’m lost…

Is there some documentation somewhere on how this all works, or do we
just need to scour the forums and slowly piece things together?