Making any edit causes the application to freeze for a few seconds

Windows 10 Home, latest version. Atom v1.34.0.

Whenever I make an edit to any file (typing a single character, typing multiple characters then stopping) in Atom, the application stops working for around 5 to 10 seconds. The top bar still works fine (can open tabs like File, Edit, View, etc), but everything else just stops working.

Can I get some help? All suggestions and answers are welcome. Thanks!

1 Like

Does this happen in safe mode (open from command line with atom --safe)?

For some odd reason, trying to run atom at all causes an error:

'atom' is not recognized as an internal or external command, operable program or batch file.

Looks like the shell commands weren’t installed correctly. I’m not very familiar with troubleshooting on Windows, but I believe there have been issues on this forum that have a fix. Alternatively, reinstalling may work.

You should also be able to open safe mode through an existing window with Application: Open Safe in the command palette.

FYI the current Atom version is 1.43.0, so you might want to see if that helps.

I accidentally typed the wrong version, haha! I meant to say 1.43.0. Sorry about that.

Anyways, I’ve tested in safe mode, and it turns out that it functions normally with no issue. I guess the issue could be with an installed package; which package specifically, I’m not sure of. Here’s a nifty list of my installed packages:

The image must be viewed in full to see all the packages I have installed. Some of them may be cut off from the image embedding on this forum.

Not sure, but I’d check these first:

  • atom-beautify
  • git-blame
  • git-plus
  • git-time-machine
  • highlight-selected
  • minimap & minimap-pigments
  • pigments
  • turbo-javascript

Basically anything that may do something on each keypress. Reload the window every time you disable some packages to ensure they are fully unloaded. Also check the dev tools (Window: Toggle Dev Tools) for any errors something might be throwing.

Alright; I’ll do that now. I’ll make another reply when I’ve tested everything.

So I did a couple of things. Firstly, i disabled all the packages listed in your reply; behavior exhibited in safe mode was the same here.

Then, I enabled those listed packages one by one. Here were my results:

  • turbo-javascript, minimap, highlight-selected, git-time-machine, git-plus, git-blame, atom-beautify: nothing happened.
  • pigments: crashed the application upon enabling. never actually enabled upon reloading the application.

In other words, pigments was clearly the main culprit here. Thank you so much for the help!

1 Like

In other news, I’ve used this article on StackOverflow to assist with adding atom to the environment variables. Thanks again for the help!

I’ve had the same problem with pigments, but I love it so don’t want to disable it. What I have done is edited some of the settings so it only runs on the filetypes I actually use (.scss in my case). It certainly seems to have helped somewhat. I also changed the timeout of the package re-running after typing to 500 ms instead of 300.