MacOS Update Causes Atom to be unusable


#1

Take a look at this gif. When I updated Mac to the most recent security update, Atom became unusable. When my curser is on any given line, I am unable to see that line or the one above it as the two lines are show as being on top of each other.


#2

I am on OS X 10.9.5 also (just upgraded last night) and I cannot reproduce this issue. Also, I notice that you have a little red bug down in the lower right of your screenshot. Have you tried clicking on that to see which package may be broken?

Additionally, have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

Thanks…I did not notice that red bug icon…I ran updates on plugins and it fixed the issue. The error it was giving me prior to updates was with pty.js. All good now though, after updating the installed plugins


#4

I don’t know if it’s possible to edit the title of the thread, but seeing this title in the weekly digest on my iPhone while I was rebooting to install the OS X update nearly gave me a heart attack!


#5

:laughing: Yes, it is possible … though I prefer to let the original author of the topic do such things.


#6

Have you tried to do View > Reload ? This saving me from a previous case when I was unable to show the Settings panel! :wink: