Mac OS 10.15.7 incompatibility?

When I try to open a separate browser window to load the code, per instructions in a Udacity coding course, I get an error message saying I need an update. When I run System Update, I get an error message after loading over 400 MB of the 441.6 MB total file, as follows:
“Command Line Tools for Xcode” is no longer needed for your computer, or is already installed.

I have tried several times, turned the computer on and off to reset the browser, etc. Any ideas how to resolve this? I’m a relative Luddite and newbie, so please make any instructions very specific, not assuming I know code short cuts.

TIA

Same issue, I don’t know what I can do.

Same, but without having Atom installed :grinning: Must be some generic problem.