Lost my tooltips


#1

I use Atom with the angularjs and atom-typescript plugins. It would be very useful to get tooltips to see Type Information on hover (which is a feature of atom-typescript). Unfortunately they don’t seem to be working. I’ve tried resetting Atom back to default settings, reinstalling all plugins, but I can’t seem to get the tooltips to display.

Is there an easy fix for this?

Thanks.


#2

Is there a point where the tooltips worked for you, or have you never been able to see them?


#3

My memory is somewhat hazy, but I remember that I thought they were getting in the way so I may have turned them off somehow. Now I can’t remember what I did, and resetting the .atom directory didn’t reset things back to stock settings enough to get it back.


#4

With my current configuration, I actually see two sets of tooltips in Typescript files (I don’t do any serious TS work, but I have a TS repo locally, so I’ve had the package installed). Are you talking about the blue one?


#5

Yes, I think it’s the blue one that I need.


#6

I haven’t figured out how to turn that off, but I think I would want to before doing much work in TypeScript. The tooltip in the back (which has the same content) is generated by atom-ide-ui and ide-typescript. If you download those two packages, do you see a similar popup?

Mind sharing your tsconfig.json for that project?


#7

I don’t seem to have that file in my project. Could that be the problem? Should I create one? I do have both those packages installed.


#8

No. When I rename my tsconfig.json file, neither of the tooltips go away.

It’s possible that you have another package installed that’s interfering with things happening on hover. On the command line, you can get a list of all your packages using the command apm ls. You can use the .atom/config.cson setting "*".core.disabledPackages to disable a large number of packages at once and see if the tooltip works with only atom-typescript or atom-ide-ui/ide-typescript enabled. Here’s an example of that setting from my computer:


#9

Very strange. I disabled all community packages except for atom-ide-ui and atom-typescript and I still get no tooltips. I’m not sure what the heck I did to break this.