Long lines after a point will not get syntax highlighting


#1

Long lines after a point will not get syntax highlighting and that is irritating a bit. I know theres a performance issue there, that is why theres a limit but can this be “solved” somehow? Wrapping lines is no solution for this unfortunately.


#2

How long is the line? can you paste me an example.
I will see if i can reproduce . if is a bug you can make a bug report.


#3

This is the line but I did try with a short php line pasting it until it started not to highlight it and got the same result there too.

Hosszúsági fok: <strong>{{ $client_geodata->longitude or '-' }}</strong>, Ország kód: <strong>{{ $client_geodata->countryCode or '-' }}</strong>, Ország: <strong>{{ $client_geodata->countryName or '-' }}</strong>, Megye: <strong>{{ $client_geodata->regionName or '-' }}</strong>, Város: <strong>{{ $client_geodata->cityName or '-' }}</strong>, Irányítószám: <strong>{{ $client_geodata->zipCode or '-' }}</strong>, Időzóna: <strong>{{ $client_geodata->timeZone or '-' }}<br>

#4

Atom has a cap of 100 tokens per line. This is hard coded, but it can be changed if you want to make a custom build.


#5

I would much prefer to have a plugin that lets me modify it honestly.


#6

Why would a package be relevant? If maxTokensPerLine were adjustable, there would just be another config field in the Settings pane.

Anyway, feel free to submit a feature request or pull request on the GitHub repo.


#7

The only way to solve this would be to completely rewrite the grammar system. It is something that we want to do long-term but there are other things that are currently higher priority.

There is already an open Issue here:

Please don’t open a new one.


#8

I wont, thank you for the help, I should wait patiently! :stuck_out_tongue:


#9

Haven’t test yet but you could give a try.


#10

I did try that but it didnt do anything or i didnt understand how it works.