Linux: Node pre version detected?


#1

Ok so I am feebly attempting to build atom on my temporary Linux box, because… well for shits’n’giggles really.

It took me a while to get a recent node version installed, as all standard methods gave me node v0.6 for some reason.
But finally I got 0.10.30 installed (see bottom of the screenshot).

And yet… node gyp seems to believe I have 0.11.14-pre installed and freaks out.

So… well… I mean… Why? :confused:


#2

Atom installs and uses its own Node.


#3

@mark_hahn is right about atom shipping with node, but I thought I read the latest atom version use 0.11.13, so it seems weird that it try to use a 0.11.14-pre. On a side note have you tried to install node through nvm? It should have much more recipes for node that the linux ppas.


#4

I haven’t tried nvm actually, didn’t think of that. I suppose that should really allow me to specify the exact version I want.
I’ll report back on that.

But do I understand correctly that, because atom comes with it, I should not even need to have node installed?


#5

Incorrect. You need to have Node.js v0.10.x to build Atom. Higher versions of Node.js might work, but not guaranteed to work AFAIK.

The bundled version of Node.js is for runtime purposes.


#6

That’s what I thought. That talk of bundled node confused me there for a moment. Ok, no worries.


#7

Changing the node version via nvm worked.
I had to make sure the nvm -selected version was made available globally, but after that I was able to complete the rest of the build.

For reference, this article was very helpful in doing that.