Linux fonts: Which are available?


#1

Compiled and installed Atom from the AUR and I was wondering where Atom gets its fonts from, whether it be xorgs fonts or fonts available from fc-list. For whatever reason, it seems like a plethora of the fonts I have installed are not recognized by Atom (either that or I’m using the wrong names).

Thanks!


[SOLVED] Fonts are not applied
#2

My installation recognises the fonts I have installed in my system. For instance if I want to use Droid Sans Mono (provided by the fonts-droid package) I can set the font as driod sans mono, DrOiD SANS mono (i.e., the case doesn’t matter). It also works for the fonts located in ‘/home/user/.local/share/fonts’.

However, you cannot set the font weight; it will always use the regular version of each font. For instance let’s say I want to use Helvetica Neue LT Std Bold or Helvetica Neue LT Std 75 Bold Outline. Let the images speak by themselves:
Helvetica Neue LT Std, Helvetica Neue LT Std Bold, Helvetica Neue LT Std 75 Bold Outline

The conclusion is that what matters is the Family name, which you can easily know opening the corresponding .ttf or .otf font files (see the example below).


#3

May I ask what you’re using to view fonts?

I seem to be limited to TTF files that are installed on the system; fonts which are in pcf like Gohu/Tewi don’t seem to be recognized.

I did have to restart X in order to add fonts I had installed which opened up quite a few options (notably Anonymous Pro)

At this point I’d like this to be more of a reference for people wondering the same thing since I’m happier now with what i have


#4

Actually, you may be able to coerce Atom into using a different font weight. I use Source Code Pro and in other editors I used the light font weight … and ran into the same problem as you. Someone else here on the board noted that the string “SourceCodePro-Light” works to tell Atom to use the Light weight of the Source Code Pro font on OS X. I don’t know if that will help on Linux … but it might be worth a shot.


#5

I’ve tried that and apparently, as I stated before, the GNU/Linux version only accepts the Font Family name, that is, the only way to use SourceCodePro is to set Atom to use “source code pro” (SourceCodePro or SourceCodePro-Light don’t work for me). Maybe OS X and Linux handle the fonts in very different ways.


#6

gnome-font-viewer 3.12 (I use Ubuntu GNOME 14.04).

Sadly I only have TTF and OTF fonts, so I cannot test the PCF format.

PS. What would be great is that the font selector be a dropdown menu.


#7

Agreed. Dropdown would make this much easier.

I’m using Arch but adding in the font viewer would be really useful (xfontsel is pretty ugly) so thank you for that.


#8

I may be wrong, but I think you can’t use .pcf because it is a bitmap font. You also can’t use bitmap fonts in any of the office suits (well, I was never able to get them recognized).


#9

Hi, I got here because I was searching the Internets for a good font to use for Atom on Ubuntu. Because of this thread I found out how to look for a good font. Tnx for the info.

Now for the next one who stumbles upon this and noticed that monospace doesn’t get you monospace in Atom.
Ubuntu Mono and Droid Sans Mono will get you a monospaced variant. I find the first, the closest to the Sublime default font.


#10

What font does monospace get you in Atom? I would think this would be a bug in Chromium and therefore in Chrome …


#11

It gets me Inconsolata, Monaco, Consolas, 'Courier New', Courier and Courier New gets rendered.


#12

Courier New is a monospaced font. Maybe I’m being dense, but I’m missing the point. :worried:


#13

I tested monospace in Chromium 34.0.1847.116 Ubuntu 14.04 aura (260972) and DejaVu Sans Mono get rendered.


#14

You are just enthusiastic :wink:

Here is some context for you.

My initial concern was that monospace doesn’t look that much like monospace in Sublime or when I Googled it. The Courier New alternative is very dense compared to what other editors/browsers show as monospace.

Anyway my case is closed, tnx!


#15

This thread was closed, but the issue remains. I can’t select variations within a font in Ubuntu. Example: I can select ‘Input Mono’, but not ‘Input Mono Medium’


#16

To select different font weights, you can always use this in your styles.less:

atom-text-editor::shadow {
    font-weight: 500;
}

According to the list on font-weight on MDN, 500 generally equates to “medium”.


#17

Thanks leedohm, unfortunately I tried both that and:

.editor {
font-weight:500;
}

500 does nothing. 600 gives me bold.


#18

Did you try 400 or 300 then? Font authors are a fickle lot … always flaunting convention and whatnot :wink:


#19

ha… anything lower than 600 renders as 300